summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-11-09 16:39:57 -0500
committerAndrew Sun2018-11-09 16:39:57 -0500
commitc4e3f22b9e981f9d823d3569d1dd10a5bd2b3711 (patch)
treec8d872e44fdb6685572a7286ed732a5b56b9ad8b
parent2af8c5c03c3e9eb32eb089f8a02b5591df577fb0 (diff)
downloadaur-c4e3f22b9e981f9d823d3569d1dd10a5bd2b3711.tar.gz
mingw-w64-xerces-c: update to 3.2.2
-rw-r--r--.SRCINFO8
-rw-r--r--002-duplicate-instantiation.patch10
-rw-r--r--PKGBUILD24
3 files changed, 29 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cf6e83cfa8b..519d83b87d5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-xerces-c
pkgdesc = A validating XML parser written in a portable subset of C++ (mingw-w64)
- pkgver = 3.2.1
+ pkgver = 3.2.2
pkgrel = 1
url = http://xerces.apache.org/xerces-c/
arch = any
@@ -11,12 +11,14 @@ pkgbase = mingw-w64-xerces-c
options = !strip
options = !buildflags
options = staticlibs
- source = http://apache.osuosl.org/xerces/c/3/sources/xerces-c-3.2.1.tar.gz
+ source = http://apache.osuosl.org/xerces/c/3/sources/xerces-c-3.2.2.tar.gz
source = 001-no-undefined.patch
source = fix-cross-compile.patch
- md5sums = fe951ca5d93713db31b026fab2d042d7
+ source = 002-duplicate-instantiation.patch
+ md5sums = 7aac41029b0d7a5eadd31cc975b391c2
md5sums = ca44fe043987da1f54e00d1aba3e6012
md5sums = 0fd713ab5edac90c99462f8869193868
+ md5sums = 38dcb94149cfd0f7ab6e17a7b80cd143
pkgname = mingw-w64-xerces-c
diff --git a/002-duplicate-instantiation.patch b/002-duplicate-instantiation.patch
new file mode 100644
index 000000000000..148b61d60b48
--- /dev/null
+++ b/002-duplicate-instantiation.patch
@@ -0,0 +1,10 @@
+--- xerces-c-3.2.2/src/xercesc/util/JanitorExports.cpp.orig 2018-11-09 11:21:18.028722000 +0300
++++ xerces-c-3.2.2/src/xercesc/util/JanitorExports.cpp 2018-11-09 11:21:28.402315400 +0300
+@@ -19,7 +19,5 @@
+
+ XERCES_CPP_NAMESPACE_BEGIN
+
+-template class ArrayJanitor<XMLByte>;
+-template class ArrayJanitor<XMLCh>;
+
+ XERCES_CPP_NAMESPACE_END
diff --git a/PKGBUILD b/PKGBUILD
index ee1b284fae64..bd9e8607e892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Sun <adsun701@gmail.com>
pkgname=mingw-w64-xerces-c
-pkgver=3.2.1
+pkgver=3.2.2
pkgrel=1
pkgdesc="A validating XML parser written in a portable subset of C++ (mingw-w64)"
arch=(any)
@@ -12,17 +12,21 @@ depends=('mingw-w64-crt')
options=('!strip' '!buildflags' 'staticlibs')
source=("http://apache.osuosl.org/xerces/c/3/sources/xerces-c-${pkgver}.tar.gz"
"001-no-undefined.patch"
- "fix-cross-compile.patch")
-md5sums=('fe951ca5d93713db31b026fab2d042d7'
+ "fix-cross-compile.patch"
+ "002-duplicate-instantiation.patch")
+md5sums=('7aac41029b0d7a5eadd31cc975b391c2'
'ca44fe043987da1f54e00d1aba3e6012'
- '0fd713ab5edac90c99462f8869193868')
+ '0fd713ab5edac90c99462f8869193868'
+ '38dcb94149cfd0f7ab6e17a7b80cd143')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/xerces-c-${pkgver}"
- patch -p1 -i "${srcdir}/001-no-undefined.patch"
+ cd "${srcdir}/xerces-c-${pkgver}"
+ patch -p1 -i "${srcdir}/001-no-undefined.patch"
patch -p1 -i "${srcdir}/fix-cross-compile.patch"
+ patch -p1 -i "${srcdir}/002-duplicate-instantiation.patch"
+
autoreconf -fiv
}
@@ -31,8 +35,8 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
- --without-icu \
- --without-curl
+ --without-icu \
+ --without-curl
make
popd
done
@@ -43,7 +47,7 @@ package() {
cd "${srcdir}/xerces-c-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}