summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2024-04-05 08:35:55 +0800
committerpingplug2024-04-05 08:35:55 +0800
commit61293b3690145479db0ffde8e7c68a82f32a4047 (patch)
tree33cdf439d9a2ffa64d8916b97e63c5ef3f8cbdd9
parent681b1a14786c8f8ecc94987b1e7b7eec2df109b5 (diff)
downloadaur-mingw-w64-xz.tar.gz
updated to 5.6.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7766cb332ca..662888788202 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-xz
pkgdesc = Library and command line tools for XZ and LZMA compressed files (mingw-w64)
- pkgver = 5.6.0
+ pkgver = 5.6.1
pkgrel = 1
url = https://xz.tukaani.org/xz-utils/
arch = any
@@ -8,14 +8,14 @@ pkgbase = mingw-w64-xz
license = GPL
license = LGPL
makedepends = mingw-w64-configure
+ makedepends = git
+ makedepends = po4a
+ makedepends = doxygen
depends = mingw-w64-crt
options = !strip
options = staticlibs
options = !buildflags
- source = https://github.com/tukaani-project/xz/releases/download/v5.6.0/xz-5.6.0.tar.gz
- source = https://github.com/tukaani-project/xz/releases/download/v5.6.0/xz-5.6.0.tar.gz.sig
- validpgpkeys = 22D465F2B4C173803B20C6DE59FCF207FEA7F445
- sha256sums = 0f5c81f14171b74fcc9777d302304d964e63ffc2d7b634ef023a7249d9b5d875
+ source = git+https://git.tukaani.org/xz.git#tag=v5.6.1
sha256sums = SKIP
pkgname = mingw-w64-xz
diff --git a/PKGBUILD b/PKGBUILD
index cedc86a569cf..52c4dab420d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,30 @@
# Contributor: Philip A Reimer < antreimer at gmail dot com >
# Contributor: Schala Zeal < schalaalexiazeal at gmail dot com >
+_pkgname=xz
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-xz
-pkgver=5.6.0
+pkgver=5.6.1
pkgrel=1
pkgdesc="Library and command line tools for XZ and LZMA compressed files (mingw-w64)"
arch=('any')
url="https://xz.tukaani.org/xz-utils/"
license=('custom' 'GPL' 'LGPL')
depends=('mingw-w64-crt')
-makedepends=('mingw-w64-configure')
+makedepends=('mingw-w64-configure' 'git' 'po4a' 'doxygen')
options=('!strip' 'staticlibs' '!buildflags')
-source=("https://github.com/tukaani-project/xz/releases/download/v${pkgver}/xz-${pkgver}.tar.gz"{,.sig})
-sha256sums=('0f5c81f14171b74fcc9777d302304d964e63ffc2d7b634ef023a7249d9b5d875'
- 'SKIP')
-validpgpkeys=('22D465F2B4C173803B20C6DE59FCF207FEA7F445') # Jia Tan <jiat0218@gmail.com>
+source=("git+https://git.tukaani.org/xz.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./autogen.sh
+}
build() {
- cd "${srcdir}/xz-${pkgver}"
+ cd "${srcdir}/${_pkgname}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure
@@ -31,7 +36,7 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/xz-${pkgver}/build-${_arch}"
+ cd "${srcdir}/${_pkgname}/build-${_arch}"
make DESTDIR="${pkgdir}" install
find "${pkgdir}/usr/${_arch}" -name '*.exe' | xargs -rtl1 rm
find "${pkgdir}/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x