summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2015-06-12 10:21:42 +0800
committerpingplug2015-06-12 10:21:42 +0800
commitf2464863e7edd3f1bcfec7c0be18a27de6255602 (patch)
tree8875a7f3020c10c68c138a29ddadca8c023fe8a4
downloadaur-f2464863e7edd3f1bcfec7c0be18a27de6255602.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee6aa7dd5626
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Mon Mar 2 08:49:16 UTC 2015
+pkgbase = mingw-w64-xz
+ pkgdesc = Library and command line tools for XZ and LZMA compressed files (mingw-w64)
+ pkgver = 5.2.1
+ pkgrel = 1
+ url = http://tukaani.org/xz
+ arch = any
+ license = custom
+ license = GPL
+ license = LGPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://tukaani.org/xz/xz-5.2.1.tar.gz
+ md5sums = 3e44c766c3fb4f19e348e646fcd5778a
+
+pkgname = mingw-w64-xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..371fcdfdf6cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: pingplug <pingplug@foxmail.com>
+# Contributor: Philip A Reimer <antreimer@gmail.com>
+# Contributor: Schala Zeal <schalaalexiazeal@gmail.com>
+
+pkgname=mingw-w64-xz
+pkgver=5.2.1
+pkgrel=1
+pkgdesc="Library and command line tools for XZ and LZMA compressed files (mingw-w64)"
+arch=('any')
+url="http://tukaani.org/xz"
+license=("custom" "GPL" "LGPL")
+makedepends=("mingw-w64-configure")
+depends=("mingw-w64-crt")
+options=(staticlibs !strip !buildflags)
+source=("$url/xz-${pkgver}.tar.gz")
+md5sums=('3e44c766c3fb4f19e348e646fcd5778a')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/xz-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/xz-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ rm "$pkgdir/usr/${_arch}/bin/"{lz{cmp,diff,egrep,fgrep,grep,less,more},xz{cmp,diff,egrep,fgrep,grep,less,more}}
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+}
+