summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2017-03-15 09:47:43 +0100
committerDario Ostuni2017-03-15 09:47:43 +0100
commit264900581c3468ae298e48ba99f3fb8868cb1856 (patch)
tree9b300073d0ad4ed4af4852c10081c8d0818fa8dc
parent778b31f1aa3cf92a78897852a7406bb8059b0dd8 (diff)
downloadaur-264900581c3468ae298e48ba99f3fb8868cb1856.tar.gz
Don't build the executables (thanks cdkitching for the tip)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b982231216c5..b88964f70ebd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Feb 18 15:32:18 UTC 2016
+# Wed Mar 15 08:47:34 UTC 2017
pkgbase = mingw-w64-yaml-cpp
pkgdesc = YAML parser and emitter in C++, written around the YAML 1.2 spec (mingw-w64)
pkgver = 0.5.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/jbeder/yaml-cpp
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 66007c9d57c3..40f192bc63a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yaml-cpp
pkgname=mingw-w64-${_pkgname}
pkgver=0.5.3
-pkgrel=3
+pkgrel=4
pkgdesc="YAML parser and emitter in C++, written around the YAML 1.2 spec (mingw-w64)"
url="https://github.com/jbeder/yaml-cpp"
arch=('any')
@@ -21,9 +21,9 @@ build() {
unset LDFLAGS
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake .. -DCMAKE_INSTALL_PREFIX=/usr/${_arch} -DBUILD_SHARED_LIBS=OFF
+ ${_arch}-cmake .. -DCMAKE_INSTALL_PREFIX=/usr/${_arch} -DBUILD_SHARED_LIBS=OFF -DYAML_CPP_BUILD_TOOLS=OFF
make
- ${_arch}-cmake .. -DCMAKE_INSTALL_PREFIX=/usr/${_arch} -DBUILD_SHARED_LIBS=ON
+ ${_arch}-cmake .. -DCMAKE_INSTALL_PREFIX=/usr/${_arch} -DBUILD_SHARED_LIBS=ON -DYAML_CPP_BUILD_TOOLS=OFF
make
popd
done