summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseth2022-07-13 01:14:24 -0400
committerseth2022-07-13 01:14:24 -0400
commit8e8f5183bfc3a0744c301e18d665160e4a7ca91f (patch)
tree44bed8fb75d7abc06bd9efd1a35d3e5392a1be6a
parentf91e6c12a93485ea427915a7d83f1b264e40db88 (diff)
downloadaur-8e8f5183bfc3a0744c301e18d665160e4a7ca91f.tar.gz
change maintainer
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD34
3 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e34fee49e71..e8e35f6d564d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = mingw-w64-zstd
pkgdesc = Zstandard - Fast real-time compression algorithm (mingw-w64)
pkgver = 1.5.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.zstd.net/
- arch = any
+ arch = x86_64
license = BSD
license = GPL2
makedepends = mingw-w64-cmake
@@ -11,7 +11,7 @@ pkgbase = mingw-w64-zstd
options = staticlibs
options = !buildflags
options = !strip
- source = https://github.com/facebook/zstd/releases/download/v1.5.2/zstd-1.5.2.tar.gz
+ source = zstd-1.5.2.tar.gz::https://github.com/facebook/zstd/archive/refs/tags/1.5.2.tar.gz
sha256sums = 7c42d56fac126929a6a85dbc73ff1db2411d04f104fae9bdea51305663a83fd0
pkgname = mingw-w64-zstd
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..511f61298ee9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.tar*
+*.log
+.BUILDINFO
+.MTREE
+.PKGINFO
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index f1c49072ae29..e1d6ae9f3ed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,51 @@
+# Maintainer: seth <getchoo at tuta dot io>
+# Contributor: xantares
+
pkgname=mingw-w64-zstd
+_pkgname=zstd
pkgver=1.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="Zstandard - Fast real-time compression algorithm (mingw-w64)"
url="http://www.zstd.net/"
-arch=('any')
+arch=('x86_64')
license=('BSD' 'GPL2')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=('staticlibs' '!buildflags' '!strip')
-source=("https://github.com/facebook/zstd/releases/download/v${pkgver}/zstd-${pkgver}.tar.gz")
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/facebook/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('7c42d56fac126929a6a85dbc73ff1db2411d04f104fae9bdea51305663a83fd0')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd zstd-$pkgver
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ export CFLAGS+=' -ffat-lto-objects'
+ export CXXFLAGS+=' -ffat-lto-objects'
for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DZSTD_BUILD_PROGRAMS=OFF ../build/cmake/
+ mkdir -p "build-${_arch}" && pushd "build-${_arch}"
+ ${_arch}-cmake -S ../build/cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr/${_arch} \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DZSTD_BUILD_CONTRIB=OFF \
+ -DZSTD_BUILD_STATIC=OFF \
+ -DZSTD_BUILD_TESTS=OFF \
+ -DZSTD_PROGRAMS_LINK_SHARED=OFF \
+ -DZSTD_BUILD_PROGRAMS=OFF
make
popd
done
}
package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
for _arch in ${_architectures}; do
- cd "$srcdir"/zstd-${pkgver}/build-${_arch}
- make install DESTDIR="$pkgdir"
+ pushd "build-${_arch}"
+ make DESTDIR="${pkgdir}" install
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ popd
done
}