summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTor Vic2021-05-06 13:45:44 +0200
committerTor Vic2021-05-06 13:45:44 +0200
commit6499d9e51d67b92e32244b829e8e5b62bf1ea572 (patch)
tree3be56ea1683695777c59f047233d4f50b75c2822
downloadaur-6499d9e51d67b92e32244b829e8e5b62bf1ea572.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD24
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dca6a30b4162
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mini-benchmarker
+ pkgdesc = A simple benchmarking script using stress-ng, perf, blender etc.
+ pkgver = 0.9.r63.g2a49602
+ pkgrel = 1
+ url = https://github.com/torvic9/bash-scripts
+ arch = x86_64
+ depends = gcc
+ depends = make
+ depends = cmake
+ depends = time
+ depends = perf
+ depends = unzip
+ depends = nasm
+ depends = inxi
+ depends = argon2
+ depends = gmp
+ depends = wget
+ depends = blender
+ depends = zlib
+ depends = libdrm
+ depends = git
+ depends = python
+ source = git+https://github.com/torvic9/bash-scripts.git
+ sha512sums = SKIP
+
+pkgname = mini-benchmarker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac3b2f91fc42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Tor Vic <torvic9 AT mailbox DOT org>
+
+pkgname='mini-benchmarker'
+pkgver=0.9.r63.g2a49602
+pkgrel=1
+pkgdesc='A simple benchmarking script using stress-ng, perf, blender etc.'
+url="https://github.com/torvic9/bash-scripts"
+arch=('x86_64')
+licence=('GPL3')
+depends=('gcc' 'make' 'cmake' 'time' 'perf' 'unzip'
+ 'nasm' 'inxi' 'argon2' 'gmp' 'wget' 'blender'
+ 'zlib' 'libdrm' 'git' 'python')
+source=(git+https://github.com/torvic9/bash-scripts.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd bash-scripts/$pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd bash-scripts/$pkgname
+ install -Dm755 $pkgname.sh "$pkgdir/usr/bin/$pkgname.sh"
+}