summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-15 12:44:25 +0800
committerzxp198210052023-11-15 12:44:25 +0800
commitcfa8527e1c6123cf06913f01c8b3ca081e5defdd (patch)
tree0473b645c4a8856192055daf2d2f3b4e1daf3ca5
parent306392916a33617f0c22b01c9507c8c29e6d37f0 (diff)
downloadaur-cfa8527e1c6123cf06913f01c8b3ca081e5defdd.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD28
-rw-r--r--mini-music.sh5
3 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3be8c9867b8e..d1bf94624755 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = mini-music-bin
pkgdesc = A simple and beautiful music player.一个简单、美观的音乐播放器
pkgver = 1.5.0
- pkgrel = 5
+ pkgrel = 6
url = https://gitee.com/cgper/miniMusic
arch = x86_64
- license = MulanPSL2
- depends = bash
+ license = custom:MulanPSL2
depends = electron11
depends = hicolor-icon-theme
provides = mini-music=1.5.0
@@ -15,6 +14,6 @@ pkgbase = mini-music-bin
source = mini-music.sh
sha256sums = f451f4e717c9364e8e302e9f24e2f7a8a0573734508d96b1c48b3ff548d5b310
sha256sums = d0b16a3cb603569486834cb55fa8a539832063864793339386f5e1f646928987
- sha256sums = 1b6d447303c882e1cdd19dc1d0bd6f6b9b87dee70d3ec758212a0e4a1450153b
+ sha256sums = 4620ae7a05dae0182c4e56fc3bbce8015b3bc0668c42f4457c06acdd429228be
pkgname = mini-music-bin
diff --git a/PKGBUILD b/PKGBUILD
index a383cb6498db..e09d38310f07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,36 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=mini-music-bin
-_appname="迷你音乐"
+_pkgname="迷你音乐"
pkgver=1.5.0
-pkgrel=5
+pkgrel=6
pkgdesc="A simple and beautiful music player.一个简单、美观的音乐播放器"
arch=('x86_64')
url="https://gitee.com/cgper/miniMusic"
-_githuburl="https://github.com/CGPer/miniMusic"
-license=('MulanPSL2')
+_ghurl="https://github.com/CGPer/miniMusic"
+license=('custom:MulanPSL2')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron11' 'hicolor-icon-theme')
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/V${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
+depends=(
+ 'electron11'
+ 'hicolor-icon-theme'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/V${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
"LICENSE::${url}/raw/V${pkgver}/LICENSE"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('f451f4e717c9364e8e302e9f24e2f7a8a0573734508d96b1c48b3ff548d5b310'
'd0b16a3cb603569486834cb55fa8a539832063864793339386f5e1f646928987'
- '1b6d447303c882e1cdd19dc1d0bd6f6b9b87dee70d3ec758212a0e4a1450153b')
-prepare() {
+ '4620ae7a05dae0182c4e56fc3bbce8015b3bc0668c42f4457c06acdd429228be')
+build() {
bsdtar -xf "${srcdir}/data.tar.xz"
- sed "s|\"/opt/${_appname}/${pkgname%-bin}\" %U|${pkgname%-bin}|g;s|DesktopApp|AudioVideo|g" \
+ sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\" %U|${pkgname%-bin}|g;s|DesktopApp|AudioVideo|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${_appname}/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_pkgname}/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 32x32 64x64 128x128 256x256 512x512;do
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/mini-music.sh b/mini-music.sh
index 5a374e061031..b21cbceb644a 100644
--- a/mini-music.sh
+++ b/mini-music.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron11
-_ASAR="/opt/mini-music/app.asar"
+APPDIR="/usr/lib/mini-music"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else