summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2020-08-08 00:49:08 +0200
committerFilippo Berto2020-08-08 00:49:08 +0200
commit35d29da43c65d3f7d0b9d872a43a10428872aaec (patch)
tree5a6147eedfc007f9dd1c17d651cc27ef02485b6d
downloadaur-35d29da43c65d3f7d0b9d872a43a10428872aaec.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0814ba98d55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mini-ndn-git
+ pkgdesc = Lightweight networking emulation tool that enables testing, experimentation, and research on the NDN platform based on Mininet
+ pkgver = v0.4.0.r34.g76dbe66
+ pkgrel = 1
+ url = https://github.com/named-data/mini-ndn
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = boost
+ depends = ndn-cxx
+ depends = ndn-nfd
+ depends = ndn-chronosync
+ depends = ndn-tools
+ depends = ndn-nlsr
+ depends = ndn-infoedit
+ depends = mininet
+ depends = termshark
+ depends = python-igraph
+ depends = python-setuptools
+ provides = mini-ndn
+ conflicts = mini-ndn
+ source = git+https://github.com/named-data/mini-ndn.git
+ sha256sums = SKIP
+
+pkgname = mini-ndn-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3049900c73c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Filippo Berto <berto.f@protonmail.com>
+_reponame=mini-ndn
+_pkgname=mini-ndn
+pkgname=${_pkgname}-git
+pkgver=v0.4.0.r34.g76dbe66
+pkgrel=1
+# epoch=
+pkgdesc="Lightweight networking emulation tool that enables testing, experimentation, and research on the NDN platform based on Mininet"
+arch=('i686' 'x86_64')
+url="https://github.com/named-data/${_reponame}"
+license=('GPL')
+groups=()
+depends=('boost' 'ndn-cxx' 'ndn-nfd' 'ndn-chronosync' 'ndn-tools' 'ndn-nlsr' 'ndn-infoedit' 'mininet' 'termshark' 'python-igraph' 'python-setuptools')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=("git+${url}.git")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_reponame}"
+ mkdir -p "${srcdir}/output"
+ python3 setup.py build
+}
+
+package() {
+ install -dm 755 "${pkgdir}/usr/local/etc/mini-ndn/"
+
+ cd "${srcdir}/${_reponame}"
+ cp topologies/*.conf "${pkgdir}/usr/local/etc/mini-ndn/"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}