summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaël Kerbiriou2019-12-01 14:48:39 +0000
committerMaël Kerbiriou2019-12-01 14:48:39 +0000
commit8548cfb1e013ea1a47ce6c8aff87c838e9ef50eb (patch)
tree6e6b27fa59df297963082b7401b273c6b2826ded
downloadaur-8548cfb1e013ea1a47ce6c8aff87c838e9ef50eb.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD48
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd8bf2c4e94a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = minia-git
+ pkgdesc = short-read assembler based on a de Bruijn graph
+ pkgver = 3.2.1.r12.g5b131b9
+ pkgrel = 1
+ url = https://github.com/GATB/bcalm
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ makedepends = cmake
+ depends = gcc-libs
+ depends = zlib
+ provides = minia
+ conflicts = minia
+ source = git+https://github.com/GATB/minia.git
+ source = git+https://github.com/GATB/gatb-core.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = minia-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ac24408e5e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Maël Kerbiriou <m431.kerbiriou@gmail.com>
+
+pkgname=minia-git
+_pkgname=minia
+pkgver=3.2.1.r12.g5b131b9
+pkgrel=1
+pkgdesc="short-read assembler based on a de Bruijn graph"
+arch=('i686' 'x86_64')
+url="https://github.com/GATB/bcalm"
+license=('AGPL3')
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+depends=('gcc-libs' 'zlib')
+makedepends=('cmake')
+source=("git+https://github.com/GATB/minia.git"
+ "git+https://github.com/GATB/gatb-core.git")
+md5sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd "$_pkgname"
+ git submodule init
+ git config submodule.thirdparty/gatb-core.url "$srcdir/gatb-core"
+ git submodule update
+}
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ builddir="$srcdir/$_pkgname/build"
+ mkdir -p "$builddir"
+ cd "$builddir"
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=True
+ make
+}
+
+check() {
+ cd "$srcdir/$_pkgname/test"
+ ./simple_test.sh
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 build/bin/minia "$pkgdir/usr/bin/minia"
+ install -Dm755 build/bin/merci "$pkgdir/usr/bin/merci"
+}