summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjadelord2019-08-01 17:21:47 +0200
committerjadelord2019-08-01 17:21:47 +0200
commit9350edebf9b10301096d60273ad8547cfb1673d8 (patch)
treeb6db8ba5ac744bae17bb09ae77efac3c7d47f2d1
parent7605ca5770d8a795ebe0be638ab65e2338c9a2c9 (diff)
downloadaur-9350edebf9b10301096d60273ad8547cfb1673d8.tar.gz
Update to 4.7.10 and remove prepare patch step
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b8d9d2f8ce6..dad4f017094b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = miniconda3
pkgdesc = Mini version of Anaconda Python distribution.
- pkgver = 4.6.14
+ pkgver = 4.7.10
pkgrel = 1
url = https://conda.io/en/latest/miniconda.html
install = miniconda3.install
@@ -9,9 +9,9 @@ pkgbase = miniconda3
options = !strip
options = libtool
options = staticlibs
- source = https://repo.continuum.io/miniconda/Miniconda3-4.6.14-Linux-x86_64.sh
+ source = https://repo.continuum.io/miniconda/Miniconda3-4.7.10-Linux-x86_64.sh
source = miniconda3.install
- sha256sums = 0d6b23895a91294a4924bd685a3a1f48e35a17970a073cd2f684ffe2c31fc4be
+ sha256sums = 8a324adcc9eaf1c09e22a992bb6234d91a94146840ee6b11c114ecadafc68121
sha256sums = 6d6d8b5f4d2e9ca3c69464e903e292fa020c10ea6920aff5c32ebb021b84d865
pkgname = miniconda3
diff --git a/PKGBUILD b/PKGBUILD
index 5c4fc3cda071..91a664ca8e60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor : Martin Wimpress <code@flexion.org>
# Contributor : Jingbei Li <i@jingbei.li>
pkgname=miniconda3
-pkgver=4.6.14
+pkgver=4.7.10
pkgrel=1
pkgdesc="Mini version of Anaconda Python distribution."
arch=('x86_64')
@@ -12,22 +12,14 @@ license=("custom")
source=("https://repo.continuum.io/miniconda/Miniconda3-${pkgver}-Linux-x86_64.sh"
"$pkgname.install")
options=(!strip libtool staticlibs)
-sha256sums=('0d6b23895a91294a4924bd685a3a1f48e35a17970a073cd2f684ffe2c31fc4be'
+sha256sums=('8a324adcc9eaf1c09e22a992bb6234d91a94146840ee6b11c114ecadafc68121'
'6d6d8b5f4d2e9ca3c69464e903e292fa020c10ea6920aff5c32ebb021b84d865')
install="$pkgname.install"
-prepare() {
- cd "${srcdir}"
- msg2 "Patching Miniconda3-${pkgver}-Linux-x86_64.sh"
- sed \
- -e '/wc -c "\$THIS_PATH" | grep/s/!//' \
- -e "/export FORCE/s|$|;sed \"/^def update_prefix/a\\\ new_prefix='/opt/$pkgname'\" -i pkgs/.install.py|" \
- -i Miniconda3-${pkgver}-Linux-x86_64.sh
-}
package() {
prefix="${pkgdir}/opt/${pkgname}"
- LD_PRELOAD="/usr/lib/libfakeroot/libfakeroot.so"
+ LD_PRELOAD="/usr/lib/libfakeroot/libfakeroot.so"
msg2 "Packaging ${pkgname} for installation to /opt/${pkgname}"
bash "${srcdir}/Miniconda3-${pkgver}-Linux-${CARCH}.sh" -b -p $prefix -f