summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshwin Vishnu2020-06-22 18:45:05 +0200
committerAshwin Vishnu2020-06-22 18:45:05 +0200
commitde81d7f33e36e889c6650f8f659ffc372185ab28 (patch)
tree101ca5eb63ece784f4733afc36ed99c533c26550
parentad751804fabdfe42a05d886df85737186004d23d (diff)
downloadaur-de81d7f33e36e889c6650f8f659ffc372185ab28.tar.gz
Update sha256sums and give unique src name
Based on package version to prevent rebuild from cache
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6fba7a31dd5..fb1c2e37fb8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = miniconda3
pkgdesc = Mini version of Anaconda Python distribution.
pkgver = 4.8.3
- pkgrel = 1
+ pkgrel = 2
url = https://conda.io/en/latest/miniconda.html
install = miniconda3.install
arch = x86_64
@@ -9,9 +9,9 @@ pkgbase = miniconda3
options = !strip
options = libtool
options = staticlibs
- source = Miniconda3.sh::https://repo.continuum.io/miniconda/Miniconda3-py38_4.8.3-Linux-x86_64.sh
+ source = miniconda3-4.8.3.sh::https://repo.continuum.io/miniconda/Miniconda3-py38_4.8.3-Linux-x86_64.sh
source = miniconda3.install
- sha256sums = 5bbb193fd201ebe25f4aeb3c58ba83feced6a25982ef4afa86d5506c3656c142
+ sha256sums = 879457af6a0bf5b34b48c12de31d4df0ee2f06a8e68768e5758c3293b2daf688
sha256sums = 6d6d8b5f4d2e9ca3c69464e903e292fa020c10ea6920aff5c32ebb021b84d865
pkgname = miniconda3
diff --git a/PKGBUILD b/PKGBUILD
index 5b7e096cb4bc..0c79adccefcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,25 +4,25 @@
# Contributor : Jingbei Li <i@jingbei.li>
pkgname=miniconda3
pkgver=4.8.3
-pkgrel=1
+pkgrel=2
pkgdesc="Mini version of Anaconda Python distribution."
arch=('x86_64')
url="https://conda.io/en/latest/miniconda.html"
license=("custom")
-source=("Miniconda3.sh::https://repo.continuum.io/miniconda/Miniconda3-py38_${pkgver}-Linux-x86_64.sh"
+source=("miniconda3-${pkgver}.sh::https://repo.continuum.io/miniconda/Miniconda3-py38_${pkgver}-Linux-x86_64.sh"
"$pkgname.install")
options=(!strip libtool staticlibs)
-sha256sums=('5bbb193fd201ebe25f4aeb3c58ba83feced6a25982ef4afa86d5506c3656c142'
+sha256sums=('879457af6a0bf5b34b48c12de31d4df0ee2f06a8e68768e5758c3293b2daf688'
'6d6d8b5f4d2e9ca3c69464e903e292fa020c10ea6920aff5c32ebb021b84d865')
install="$pkgname.install"
package() {
prefix="${pkgdir}/opt/${pkgname}"
- LD_PRELOAD="/usr/lib/libfakeroot/libfakeroot.so"
+ LD_PRELOAD="/usr/lib/libfakeroot/libfakeroot.so"
msg2 "Packaging ${pkgname} for installation to /opt/${pkgname}"
- bash "${srcdir}/Miniconda3.sh" -b -p $prefix -f
+ bash "${srcdir}/miniconda3-${pkgver}.sh" -b -p $prefix -f
[ "$BREAK_EARLY" = 1 ] && exit 1
cd "${prefix}"