summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjadelord2018-06-02 06:05:53 +0200
committerjadelord2018-06-02 06:05:53 +0200
commitf15b6af192ce167ab86370df24cb7e20b84bc64b (patch)
treef182be74fb3495ce5fd6c8b8171cde3ecc4a0d5b
downloadaur-f15b6af192ce167ab86370df24cb7e20b84bc64b.tar.gz
First commit: derived from AUR anaconda
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD45
-rw-r--r--miniconda3.install7
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50989a44e839
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jun 2 03:50:33 UTC 2018
+pkgbase = miniconda3
+ pkgdesc = Mini version of Anaconda Python distribution.
+ pkgver = 4.5.1
+ pkgrel = 1
+ url = https://conda.io/miniconda
+ install = miniconda3.install
+ arch = x86_64
+ license = custom
+ options = !strip
+ options = libtool
+ options = staticlibs
+ source = http://repo.continuum.io/miniconda/Miniconda3-4.5.1-Linux-x86_64.sh
+ source = miniconda3.install
+ sha256sums = 4b857c96d7aad4b09063224e88f4f62e778a5f1f2a1b211340ba765ce6aa21e5
+ sha256sums = 9e0d1b0226a08e8cd220e4dbe42ecfa7636893e023e61123f70fd2bed3c3f066
+
+pkgname = miniconda3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e34472c6140
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+Miniconda3*.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89d0496bd4bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer : Ashwin Vishnu <ashwinvis+arch At protonmail DoT cOm>
+# Contributor : Immae <ismael.bouya@normalesup.org>
+# Contributor : Martin Wimpress <code@flexion.org>
+# Contributor : Jingbei Li <i@jingbei.li>
+pkgname=miniconda3
+pkgver=4.5.1
+pkgrel=1
+pkgdesc="Mini version of Anaconda Python distribution."
+arch=('x86_64')
+url="https://conda.io/miniconda"
+license=("custom")
+source=("http://repo.continuum.io/miniconda/Miniconda3-${pkgver}-Linux-x86_64.sh"
+ "$pkgname.install")
+options=(!strip libtool staticlibs)
+sha256sums=('4b857c96d7aad4b09063224e88f4f62e778a5f1f2a1b211340ba765ce6aa21e5'
+ '9e0d1b0226a08e8cd220e4dbe42ecfa7636893e023e61123f70fd2bed3c3f066')
+install="$pkgname.install"
+
+prepare() {
+ cd "${srcdir}"
+ msg2 "Patching Miniconda3-${pkgver}-Linux-x86_64.sh"
+ sed \
+ -e '/wc -c "\$THIS_PATH" | grep/s/!//' \
+ -e "/export FORCE/s|$|;sed \"/^def update_prefix/a\\\ new_prefix='/opt/$pkgname'\" -i pkgs/.install.py|" \
+ -i Miniconda3-${pkgver}-Linux-x86_64.sh
+}
+
+package() {
+ prefix="${pkgdir}/opt/${pkgname}"
+ LD_PRELOAD="/usr/lib/libfakeroot/libfakeroot.so"
+
+ msg2 "Packaging ${pkgname} for installation to /opt/${pkgname}"
+ bash "${srcdir}/Miniconda3-${pkgver}-Linux-${CARCH}.sh" -b -p $prefix -f
+ [ "$BREAK_EARLY" = 1 ] && exit 1
+ cd "${prefix}"
+
+ msg2 "Correcting permissions"
+ chmod a+r -R pkgs
+
+ msg2 "Stripping \$pkgdir from default meta"
+ find conda-meta -name '*.json' -exec sed -e "s/${pkgdir//\//\\\/}//g" -i {} \;
+
+ msg2 "Installing license"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/miniconda3.install b/miniconda3.install
new file mode 100644
index 000000000000..0406dbc23eab
--- /dev/null
+++ b/miniconda3.install
@@ -0,0 +1,7 @@
+post_install(){
+ echo -e "Please run\n"
+ echo -e "\t$ source /opt/miniconda3/bin/activate root"
+ echo -e "\t$ source /opt/miniconda3/bin/deactivate root"
+ echo -e "\nto activate and deactivate the miniconda3 enviroment.\n"
+}
+