summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Trotman2018-09-20 13:12:20 +0100
committerPeter Trotman2018-09-20 13:12:20 +0100
commit020720f5610cb962e85c1264a5e521712930beeb (patch)
treee1695d098e0de80219f1f9722347e793ecd04b19
parent63d649f6545d18d5d8ba3a175079cb915041de0e (diff)
downloadaur-020720f5610cb962e85c1264a5e521712930beeb.tar.gz
Removed v from and bumped version.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d12b9886d0a..be2b458efed0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = minikube-git
pkgdesc = Minikube is a tool that makes it easy to run Kubernetes locally.
- pkgver = v0.25.0.r96.ga000c35e1
+ pkgver = 0.28.2.r55.gbed9aabaf
pkgrel = 1
url = https://github.com/kubernetes/minikube
arch = x86_64
license = apache
makedepends = git
makedepends = go
- makedepends = make
- depends = glibc
- optdepends = kubectl-bin: to manage the cluster
+ optdepends = kubectl: to manage the cluster
optdepends = virtualbox
optdepends = docker-machine-driver-kvm2
provides = minikube
diff --git a/PKGBUILD b/PKGBUILD
index bb0ae6c1db2d..10f9a374b939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
# Upstream: https://github.com/kubernetes/minikube
pkgname=('minikube-git')
-pkgver=v0.25.0.r96.ga000c35e1
+pkgver=0.28.2.r55.gbed9aabaf
pkgrel=1
pkgdesc='Minikube is a tool that makes it easy to run Kubernetes locally.'
arch=('x86_64')
url='https://github.com/kubernetes/minikube'
license=('apache')
-depends=('glibc')
+depends=()
optdepends=(
- 'kubectl-bin: to manage the cluster'
+ 'kubectl: to manage the cluster'
'virtualbox'
'docker-machine-driver-kvm2'
)
-makedepends=('git' 'go' 'make')
+makedepends=('git' 'go')
provides=('minikube')
conflicts=('minikube')
source=("$pkgname::git+https://github.com/kubernetes/minikube.git")
@@ -23,7 +23,7 @@ md5sums=('SKIP')
pkgver() {
cd "$pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
prepare() {