summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2019-04-16 15:58:28 -0500
committerkyechou2019-04-16 15:58:28 -0500
commit6b31b25f46f0a90b2ba12dd2906c3d97255066c3 (patch)
treeb2af544615a903774e98023498950c9fcc2c205f
parent1bc7d460a9c26c8fcb08805cfa2c3a17354f4c6d (diff)
downloadaur-6b31b25f46f0a90b2ba12dd2906c3d97255066c3.tar.gz
Remove patch since 815 has been merged
-rw-r--r--.SRCINFO4
-rw-r--r--815.patch69
-rw-r--r--PKGBUILD11
3 files changed, 5 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d438c577d1b7..74ecad9d7476 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mininet-git
pkgdesc = Emulator for rapid prototyping of Software Defined Networks
- pkgver = 2.3.0d5.r3.g38e1985
+ pkgver = 2.3.0d5.r4.gc5f23b9
pkgrel = 1
url = https://github.com/mininet/mininet
install = mininet.install
@@ -30,10 +30,8 @@ pkgbase = mininet-git
provides = mininet
conflicts = mininet
replaces = mininet
- source = 815.patch
source = mininet-git::git+https://github.com/mininet/mininet.git
source = git+https://github.com/mininet/openflow.git
- sha256sums = 50e3afe543ac54553383a3c8e98b2a4ff99c58e468e30d7dd3222c8a7a902890
sha256sums = SKIP
sha256sums = SKIP
diff --git a/815.patch b/815.patch
deleted file mode 100644
index 1566c6581b2c..000000000000
--- a/815.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From a73e7766952759e7eebb656e553008f07b16a209 Mon Sep 17 00:00:00 2001
-From: Matthieu Coudron <mattator@gmail.com>
-Date: Tue, 10 Jul 2018 17:47:49 +0900
-Subject: [PATCH] fix "which" calls always returning true
-
-The redirection of stderr towards stdout means calls to "which program"
-always return something even when "program" is not installed.
-
-This patch checks for the return value instead before returning the
-value.
-
-See #814.
----
- mininet/node.py | 10 +++++-----
- mininet/util.py | 5 +++++
- 2 files changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/mininet/node.py b/mininet/node.py
-index 7429b0b6f..4423cce7c 100644
---- a/mininet/node.py
-+++ b/mininet/node.py
-@@ -63,7 +63,7 @@
- from mininet.log import info, error, warn, debug
- from mininet.util import ( quietRun, errRun, errFail, moveIntf, isShellBuiltin,
- numCores, retry, mountCgroups, BaseString, decode,
-- encode, Python3 )
-+ encode, Python3, which )
- from mininet.moduledeps import moduleDeps, pathCheck, TUN
- from mininet.link import Link, Intf, TCIntf, OVSIntf
- from re import findall
-@@ -1447,7 +1447,7 @@ def __repr__( self ):
- @classmethod
- def isAvailable( cls ):
- "Is controller available?"
-- return quietRun( 'which controller' )
-+ return which( 'controller' )
-
-
- class OVSController( Controller ):
-@@ -1459,9 +1459,9 @@ def __init__( self, name, **kwargs ):
-
- @classmethod
- def isAvailable( cls ):
-- return ( quietRun( 'which ovs-controller' ) or
-- quietRun( 'which test-controller' ) or
-- quietRun( 'which ovs-testcontroller' ) ).strip()
-+ return (which( 'ovs-controller' ) or
-+ which( 'test-controller' ) or
-+ which( 'ovs-testcontroller' ))
-
- class NOX( Controller ):
- "Controller to run a NOX application."
-diff --git a/mininet/util.py b/mininet/util.py
-index 18813188f..9ce61db1e 100644
---- a/mininet/util.py
-+++ b/mininet/util.py
-@@ -171,6 +171,11 @@ def quietRun( cmd, **kwargs ):
- "Run a command and return merged stdout and stderr"
- return errRun( cmd, stderr=STDOUT, **kwargs )[ 0 ]
-
-+def which(cmd, **kwargs ):
-+ "Run a command and return merged stdout and stderr"
-+ out, _, ret = errRun( ["which", cmd], stderr=STDOUT, **kwargs )
-+ return out.rstrip() if ret == 0 else None
-+
- # pylint: enable=maybe-no-member
-
- def isShellBuiltin( cmd ):
-
diff --git a/PKGBUILD b/PKGBUILD
index f3af555a9623..a35b4d7f61d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kuan-Yen Chou <kuanyenchou@gmail.com>
pkgname=mininet-git
-pkgver=2.3.0d5.r3.g38e1985
+pkgver=2.3.0d5.r4.gc5f23b9
pkgrel=1
pkgdesc='Emulator for rapid prototyping of Software Defined Networks'
depends=('python' 'iproute2' 'net-tools' 'iputils' 'inetutils' 'iperf' 'ethtool'
@@ -17,12 +17,10 @@ license=('custom')
provides=('mininet')
conflicts=('mininet')
replaces=('mininet')
-install='mininet.install'
-source=('815.patch'
- "$pkgname"::'git+https://github.com/mininet/mininet.git'
+install=mininet.install
+source=("$pkgname"::'git+https://github.com/mininet/mininet.git'
'git+https://github.com/mininet/openflow.git') # for the UserSwitch
-sha256sums=('50e3afe543ac54553383a3c8e98b2a4ff99c58e468e30d7dd3222c8a7a902890'
- 'SKIP'
+sha256sums=('SKIP'
'SKIP')
pkgver() {
@@ -35,7 +33,6 @@ prepare() {
sed '/^include debian\/automake.mk/d' -i Makefile.am
cd "$srcdir/$pkgname"
- git am "$srcdir/815.patch"
sed 's:PREFIX ?= /usr:PREFIX ?= "$(DESTDIR)"/usr:' -i Makefile
sed 's:$(PYTHON) setup.py install:$(PYTHON) setup.py install --prefix=/usr --root="$(DESTDIR)" --optimize=1:' -i Makefile
}