summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2020-12-24 10:58:05 -0600
committerkyechou2020-12-24 10:58:05 -0600
commit6cd09669ffd51217fab05f3c51c2667037b5ccd8 (patch)
tree527650851889baa73d61b39a87be08176efb6cf0
parent6b31b25f46f0a90b2ba12dd2906c3d97255066c3 (diff)
downloadaur-6cd09669ffd51217fab05f3c51c2667037b5ccd8.tar.gz
Update versioning scheme
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74ecad9d7476..e950b092219f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mininet-git
pkgdesc = Emulator for rapid prototyping of Software Defined Networks
- pkgver = 2.3.0d5.r4.gc5f23b9
+ pkgver = 2.3.0d6.r29.gafdf9fd
pkgrel = 1
url = https://github.com/mininet/mininet
install = mininet.install
@@ -30,8 +30,8 @@ pkgbase = mininet-git
provides = mininet
conflicts = mininet
replaces = mininet
- source = mininet-git::git+https://github.com/mininet/mininet.git
- source = git+https://github.com/mininet/openflow.git
+ source = mininet-git::git+https://github.com/mininet/mininet
+ source = git+https://github.com/mininet/openflow
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a35b4d7f61d1..02da9dde6323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kuan-Yen Chou <kuanyenchou@gmail.com>
pkgname=mininet-git
-pkgver=2.3.0d5.r4.gc5f23b9
+pkgver=2.3.0d6.r29.gafdf9fd
pkgrel=1
pkgdesc='Emulator for rapid prototyping of Software Defined Networks'
depends=('python' 'iproute2' 'net-tools' 'iputils' 'inetutils' 'iperf' 'ethtool'
@@ -18,14 +18,18 @@ provides=('mininet')
conflicts=('mininet')
replaces=('mininet')
install=mininet.install
-source=("$pkgname"::'git+https://github.com/mininet/mininet.git'
- 'git+https://github.com/mininet/openflow.git') # for the UserSwitch
+source=("$pkgname"::'git+https://github.com/mininet/mininet'
+ 'git+https://github.com/mininet/openflow') # for the UserSwitch
sha256sums=('SKIP'
'SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ if git describe --long --tags >/dev/null 2>&1; then
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ else
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+ fi
}
prepare() {