summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThor772016-04-24 21:40:47 +0200
committerThor772016-04-24 21:40:47 +0200
commitdad1c8f65767548bafac978f6c460675746baa5f (patch)
tree41cc2ad6066e9ef3348209178b735c7e5d91afa5
downloadaur-dad1c8f65767548bafac978f6c460675746baa5f.tar.gz
Initial
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..348d22d88d8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Apr 24 19:39:09 UTC 2016
+pkgbase = minion
+ pkgdesc = Minion is a relatively new constraint solver which is fast and scales well as problem size increases
+ pkgver = 2.0
+ pkgrel = 1
+ url = http://constraintmodelling.org/minion/
+ arch = i686
+ arch = x86_64
+ license = GNU General Public License Version 2
+ makedepends = python2
+ makedepends = cmake
+ source = hg+https://bitbucket.org/stacs_cp/minion
+ md5sums = SKIP
+
+pkgname = minion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54744c455772
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Thor77 <thor77 at thor77 dot org>
+
+pkgname=minion
+pkgver=2.0
+pkgrel=1
+pkgdesc="Minion is a relatively new constraint solver which is fast and scales well as problem size increases"
+arch=('i686' 'x86_64')
+url="http://constraintmodelling.org/minion/"
+license=('GNU General Public License Version 2')
+makedepends=('python2' 'cmake')
+source=("hg+https://bitbucket.org/stacs_cp/minion")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/minion"
+ mkdir -p bin
+ cd bin
+ python2 ../build.py
+ make minion
+}
+
+package() {
+ cd "$srcdir/minion/bin"
+ install -d "$pkgdir/usr/bin"
+ install -Dm 755 minion $pkgdir/usr/bin/
+}