summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Steel2015-06-08 18:30:26 +0100
committerJonathan Steel2015-06-08 18:30:26 +0100
commit42dcab3977c1b61ec0d0990eb2cabfe44e0115b6 (patch)
treef9768e0e47abfa9a78d80dfb6ed8544a8ce2370e
downloadaur-42dcab3977c1b61ec0d0990eb2cabfe44e0115b6.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
-rw-r--r--minirc.install11
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e4b43f86b46
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = minirc-git
+ pkgdesc = Minimalistic init script
+ pkgver = 120.2915396
+ pkgrel = 1
+ url = https://github.com/hut/minirc
+ install = minirc.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = busybox
+ depends = sh
+ optdepends = eudev: udev implementation
+ optdepends = mdev: udev implementation
+ optdepends = systemd: udev implementation
+ conflicts = systemd-sysvcompat
+ conflicts = sysvinit
+ backup = etc/inittab
+ backup = etc/minirc.conf
+ source = git://github.com/hut/minirc.git
+ md5sums = SKIP
+
+pkgname = minirc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dad3d39cfc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Jonathan Steel <jsteel at archlinux.org>
+# Contributor: Sam Stuewe <halosghost at archlinux dot info>
+
+_gitname=minirc
+pkgname=$_gitname-git
+pkgver=120.2915396
+pkgrel=1
+pkgdesc="Minimalistic init script"
+arch=('any')
+url="https://github.com/hut/minirc"
+license=('GPL2')
+depends=('busybox' 'sh')
+makedepends=('git')
+optdepends=('eudev: udev implementation'
+ 'mdev: udev implementation'
+ 'systemd: udev implementation')
+conflicts=('systemd-sysvcompat' 'sysvinit')
+backup=('etc/inittab' 'etc/minirc.conf')
+install=$_gitname.install
+source=(git://github.com/hut/$_gitname.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+
+ echo $(git rev-list --count HEAD).$(git describe --always)
+}
+
+prepare() {
+ cd $_gitname
+
+ sed -i 's./sbin/./usr/bin/.g' ./setup.sh
+}
+
+package() {
+ cd $_gitname
+
+ ROOT="$pkgdir" ./setup.sh --force
+
+ for i in FAQ README.md screenshot.png; do
+ install -Dm644 $i "$pkgdir"/usr/share/doc/$_gitname/$i
+ done
+}
diff --git a/minirc.install b/minirc.install
new file mode 100644
index 000000000000..aa5e30cf5eaa
--- /dev/null
+++ b/minirc.install
@@ -0,0 +1,11 @@
+post_install() {
+ if [[ -z $( grep -i 'needs_root_rights = yes' /etc/X11/Xwrapper.config 2> /dev/null ) ]]; then
+ echo '==> In order to use X, add the following to /etc/X11/Xwrapper.config
+ allowed_users = anybody
+ needs_root_rights = yes'
+ fi
+}
+
+post_upgrade() {
+ post_install
+}