summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2019-03-12 10:16:59 +0700
committerkhai96_2019-03-12 10:16:59 +0700
commitb3507dda966ce36b8c1a7f7a765e6a703a2cc779 (patch)
tree0ac9984d35542c177052b6b185486314e75f7db3
parentf31b7047a6c16536a8ab0fe3984e05ad82809295 (diff)
downloadaur-b3507dda966ce36b8c1a7f7a765e6a703a2cc779.tar.gz
Tweak some details
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 493aa3a09027..0771c0386a36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,12 @@ pkgbase = miniserve-bin
url = https://github.com/svenstaro/miniserve
arch = x86_64
license = MIT
- makedepends = curl
provides = miniserve
conflicts = miniserve
source = https://github.com/svenstaro/miniserve/releases/download/v0.3.1/miniserve-linux
- sha256sums = d8f214d619a643764367abd88301cb94b41b61fe44ece2d90a8d8c0433f3301a
+ source = https://github.com/svenstaro/miniserve/raw/v0.3.1/LICENSE
sha512sums = 3317c766508c1008b1e8aad61fd9c2b10d75b5c09e32524dd06d5e273690877ed55c836e622dcd730ad3f7af0a7397fd09e05407c6f70f0bf43713218389c672
+ sha512sums = 0e5f379c28d49033b0e44982fb94b932eb6dbb81a74656776986eb93a6e9135a89b5dc6764ae9e1ee4cc47f09526d7bf96abe0e84d94ba3198590dc3fa43f9e2
pkgname = miniserve-bin
diff --git a/PKGBUILD b/PKGBUILD
index e452feefc71b..06eb5a54153c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,23 @@
pkgname=miniserve-bin
_pkgname=miniserve
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to serve files via HTTP"
provides=('miniserve')
conflicts=('miniserve')
arch=('x86_64')
url="https://github.com/svenstaro/miniserve"
license=(MIT)
-makedepends=(curl)
-source=(https://github.com/svenstaro/miniserve/releases/download/v${pkgver}/miniserve-linux)
-sha256sums=('d8f214d619a643764367abd88301cb94b41b61fe44ece2d90a8d8c0433f3301a')
-sha512sums=('3317c766508c1008b1e8aad61fd9c2b10d75b5c09e32524dd06d5e273690877ed55c836e622dcd730ad3f7af0a7397fd09e05407c6f70f0bf43713218389c672')
+source=(
+ https://github.com/svenstaro/miniserve/releases/download/v${pkgver}/miniserve-linux
+ https://github.com/svenstaro/miniserve/raw/v${pkgver}/LICENSE
+)
+sha512sums=(
+ '3317c766508c1008b1e8aad61fd9c2b10d75b5c09e32524dd06d5e273690877ed55c836e622dcd730ad3f7af0a7397fd09e05407c6f70f0bf43713218389c672'
+ '0e5f379c28d49033b0e44982fb94b932eb6dbb81a74656776986eb93a6e9135a89b5dc6764ae9e1ee4cc47f09526d7bf96abe0e84d94ba3198590dc3fa43f9e2'
+)
package() {
- echo pkgdir $pkgdir
- install -Dm755 miniserve-linux "$pkgdir"/usr/bin/miniserve-linux
- cd "$pkgdir"/usr/bin
- ln -s miniserve-linux miniserve
+ install -Dm755 miniserve-linux "$pkgdir"/usr/bin/miniserve
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}