summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-08-09 18:57:39 -0400
committerKyle Keen2015-08-09 18:57:39 -0400
commitdcdd6aecb3e74c1687adc29342795c73aad4c519 (patch)
tree2e2c11b3ac959880e08a0269febee880c3a296e2
downloadaur-dcdd6aecb3e74c1687adc29342795c73aad4c519.tar.gz
aur3 recovery
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1c7b8b3b8cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ministat-git
+ pkgdesc = A small tool to do the statistics legwork on benchmarks etc.
+ pkgver = 20120914
+ pkgrel = 1
+ url = http://github.com/codemac/ministat
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = glibc
+ provides = ministat
+ conflicts = ministat
+ source = git+https://github.com/codemac/ministat.git
+ md5sums = SKIP
+
+pkgname = ministat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6da8215bc85c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jeff 'codemac' Mickey <jeff@archlinux.org>;
+
+pkgname=ministat-git
+pkgver=20120914
+pkgrel=1
+pkgdesc="A small tool to do the statistics legwork on benchmarks etc."
+arch=('i686' 'x86_64')
+url="http://github.com/codemac/ministat"
+license=('custom')
+depends=('glibc')
+makedepends=('git')
+provides=('ministat')
+conflicts=('ministat')
+source=('git+https://github.com/codemac/ministat.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ministat
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+
+build() {
+ cd ministat
+ make
+}
+
+package() {
+ cd ministat
+ make DESTDIR="$pkgdir" install
+}