summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Frank2019-01-01 21:27:03 -0800
committerJustin Frank2019-01-01 21:27:03 -0800
commit3af6620a29ab256a513a3c9bd6d266cc6758504d (patch)
tree88e53947107f1987ad1f6d4bb9c30f3d63ce07e6
parenta12c5b968f471c15720d65b133767db9b7d7dcc5 (diff)
downloadaur-3af6620a29ab256a513a3c9bd6d266cc6758504d.tar.gz
updated package
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6e7dd1d928b..3f5e8cea89ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = miniterm-git
pkgdesc = Lightweight VTE terminal emulator with colorscheme support (fork of tinyterm)
- pkgver = v1.2.0.0.gc4d2ae2
+ pkgver = v1.4.0.0.gc4d2ae2
pkgrel = 1
url = https://github.com/laelath/miniterm
arch = i386
arch = x86_64
license = MIT
makedepends = git
+ makedepends = cmake
depends = vte3
depends = glib2
source = git+https://github.com/laelath/miniterm.git
diff --git a/PKGBUILD b/PKGBUILD
index dfec9d7f5dd4..fd9be2432e2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=miniterm-git
_pkgname=miniterm
-pkgver=v1.2.0.0.gc4d2ae2
+pkgver=v1.4.0.0.gc4d2ae2
pkgrel=1
pkgdesc="Lightweight VTE terminal emulator with colorscheme support (fork of tinyterm)"
arch=('i386' 'x86_64')
url="https://github.com/laelath/miniterm"
license=('MIT')
depends=('vte3' 'glib2')
-makedepends=('git')
+makedepends=('git' 'cmake')
source=('git+https://github.com/laelath/miniterm.git')
md5sums=('SKIP')
@@ -20,6 +20,9 @@ pkgver() {
build() {
cd "$_pkgname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
make
}