summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Goldberg2023-08-29 18:31:04 +0200
committerChristopher Goldberg2023-08-29 18:31:04 +0200
commitbba49268eb6a71382208f894d2a508ce34af00f1 (patch)
tree8d0cccdbf2acbd60d4e4b3e914ac44667058f2a2
downloadaur-bba49268eb6a71382208f894d2a508ce34af00f1.tar.gz
initial commit for minitube-systray-git
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD30
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..402a4aa3963d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = minitube-systray-git
+ pkgdesc = A YouTube desktop application (player) with systray functionality
+ pkgver = 3.9.3
+ pkgrel = 2
+ url = https://github.com/chrisgoldberg1/minitube
+ arch = x86_64
+ license = GPL3
+ makedepends = mpv
+ makedepends = qt5-tools
+ depends = gcc-libs
+ depends = glibc
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-x11extras
+ provides = minitube
+ conflicts = minitube
+ source = git+https://github.com/chrisgoldberg1/minitube.git
+ sha512sums = SKIP
+
+pkgname = minitube-systray-git
+ depends = gcc-libs
+ depends = glibc
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-x11extras
+ depends = libmpv.so
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6b41b79fe20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christopher Goldberg
+
+pkgname=minitube-systray-git
+_pkgname=minitube
+pkgver=3.9.3
+pkgrel=2
+pkgdesc="A YouTube desktop application (player) with systray functionality"
+arch=(x86_64)
+url="https://github.com/chrisgoldberg1/minitube"
+license=(GPL3)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=(gcc-libs glibc qt5-base qt5-declarative qt5-x11extras)
+makedepends=(mpv qt5-tools)
+source=("git+https://github.com/chrisgoldberg1/minitube.git")
+
+sha512sums=("SKIP")
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ git submodule update --init --recursive
+ qmake
+}
+
+package() {
+ depends+=(libmpv.so)
+
+ make install INSTALL_ROOT="$pkgdir/" -C ${_pkgname}-$pkgver
+ install -vDm 644 ${_pkgname}-$pkgver/{AUTHORS,CHANGES,README.md,TODO} -t "$pkgdir/usr/share/doc/${_pkgname}/"
+}