summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-04-12 21:55:34 +0800
committerChocobo12023-04-12 21:55:34 +0800
commit4cd807dd8c2ac3413a1cc9d2376fab646689877a (patch)
tree9a7a271e517f648ba681415da8aaf7ff137471db
parent7ddc89882930051d62710aa4ba88e1145fbca972 (diff)
downloadaur-4cd807dd8c2ac3413a1cc9d2376fab646689877a.tar.gz
upgpkg: miniupnpd-git 2.3.3.r0.ge439318-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cd95cf3c495..84e8387661f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = miniupnpd-git
pkgdesc = Lightweight UPnP IGD daemon (git)
- pkgver = 2.2.2.r15.g6f848ae
+ pkgver = 2.3.3.r0.ge439318
pkgrel = 1
url = http://miniupnp.free.fr
arch = i686
@@ -14,7 +14,7 @@ pkgbase = miniupnpd-git
depends = net-tools
depends = util-linux
depends = sh
- provides = miniupnpd
+ provides = miniupnpd=2.3.3.r0.ge439318
conflicts = miniupnpd
backup = etc/miniupnpd/miniupnpd.conf
source = git+https://github.com/miniupnp/miniupnp.git
diff --git a/PKGBUILD b/PKGBUILD
index fc8a8525d3f4..77f8040324e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=miniupnpd-git
-pkgver=2.2.2.r15.g6f848ae
+pkgver=2.3.3.r0.ge439318
pkgrel=1
pkgdesc="Lightweight UPnP IGD daemon (git)"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="http://miniupnp.free.fr"
license=('BSD')
depends=('glibc' 'iptables' 'net-tools' 'util-linux' 'sh')
makedepends=('git' 'lsb-release' 'procps-ng')
-provides=('miniupnpd')
+provides=("miniupnpd=$pkgver")
conflicts=('miniupnpd')
backup=('etc/miniupnpd/miniupnpd.conf')
source=("git+https://github.com/miniupnp/miniupnp.git"
@@ -21,7 +21,10 @@ sha256sums=('SKIP'
pkgver() {
cd "miniupnp"
- git describe --long --tags | sed 's/^miniupnpc_//;s/^miniupnpd_//;s/\([^-]*-g\)/r\1/;s/[_-]/./g'
+ _tag=$(git tag -l --sort -v:refname | grep -E '^miniupnpd_[0-9_]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^miniupnpd_//;s/_/./g'
}
build() {