summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmeric2022-06-26 15:25:17 +0200
committerEmeric2022-06-26 15:25:17 +0200
commit22b0dfa9a9ca83303b1950e551b17cc040aad9f8 (patch)
tree0fef3bbed5e97866ee5cfa8d50b2468a5c9b55a2
downloadaur-22b0dfa9a9ca83303b1950e551b17cc040aad9f8.tar.gz
Upload first version of minivideoinfos-git
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b87311809af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = minivideoinfos-git
+ pkgdesc = Get detailed informations about your audio, video and picture files!
+ pkgver = 0.10
+ pkgrel = 1
+ url = https://github.com/emericg/MiniVideoInfos
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = qt6-tools
+ depends = qt6-base
+ depends = qt6-declarative
+ depends = qt6-quickcontrols2
+ depends = qt5-graphicaleffects
+ depends = qt6-charts
+ depends = qt6-svg
+ depends = qt6-location-dev
+ depends = minivideo-git
+ depends = libexif
+ depends = taglib
+ source = minivideoinfos-git::git+https://github.com/emericg/MiniVideoInfos.git
+ sha256sums = SKIP
+
+pkgname = minivideoinfos-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e598faddd4c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Emeric Grange <emeric.grange@gmail.com>
+
+pkgname=minivideoinfos-git
+pkgver=0.10
+pkgrel=1
+pkgdesc="Get detailed informations about your audio, video and picture files!"
+arch=("x86_64" "i686")
+url="https://github.com/emericg/WatchFlower"
+license=("GPL3")
+depends=("qt6-base" "qt6-declarative" "qt6-quickcontrols2" "qt5-graphicaleffects" "qt6-charts" "qt6-svg" "qt6-location-dev" "minivideo-git" "libexif" "taglib")
+makedepends=("qt6-tools")
+
+url="https://github.com/emericg/MiniVideoInfos"
+source=("${pkgname}::git+https://github.com/emericg/MiniVideoInfos.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${pkgname}"
+ qmake6 -config release PREFIX=${pkgdir}/usr/
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}