summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImperatorStorm2021-07-29 15:49:49 -0700
committerImperatorStorm2021-07-29 15:49:49 -0700
commitb60e93891023b84c7d9d3c4499c58d0b46a06bfa (patch)
tree54212042bdc958cd3975e07f44fbf7ca3099ecf2
parent799ed9a30208409b179a26b9db848c38dc80be3a (diff)
downloadaur-b60e93891023b84c7d9d3c4499c58d0b46a06bfa.tar.gz
Fixed package, updated to latest commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rw-r--r--pc.patch17
-rw-r--r--project_name.patch17
-rw-r--r--soversion.patch23
5 files changed, 33 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7f565fa84aa..11d8ce04be27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = minizip-git
- pkgver = 2.3.3
+ pkgdesc = Fork of the popular zip manipulation library found in the zlib distribution.
+ pkgver = 3.0.2.r0.gbc93e40
pkgrel = 1
epoch = 2
url = https://github.com/nmoinvaz/minizip
arch = x86_64
- license = custom
+ license = zlib
makedepends = git
makedepends = cmake
depends = glibc
depends = libbsd
depends = zlib
- source = git+https://github.com/nmoinvaz/minizip.git#commit=7bdfbf4
- source = soversion.patch
- source = project_name.patch
- source = pc.patch
+ provides = minizip
+ provides = minizip-ng
+ provides = minizip-git
+ conflicts = minizip
+ conflicts = minizip-ng
+ conflicts = minizip-git
+ source = git+https://github.com/zlib-ng/minizip-ng
sha256sums = SKIP
- sha256sums = 3a648c48b9af7536e03c13327bd2f680a297fc629045fd904e344674971f3569
- sha256sums = 3268ec716b89004bbc8124b3213c3bc0d15289d7771bbac82cd4c6694e390b79
- sha256sums = d45977c36a6c1b2eefbf39d829be8753cecd3d8910d1926ad842359da3b9a869
pkgname = minizip-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b9da739611a8..6e1d1b45e632 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,46 @@
-# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+# Maintainer: Imperator Storm <30777770+ImperatorStorm@users.noreply.github.com>
pkgname=minizip-git
_pkgname=minizip
epoch=2
-pkgver=2.3.3
+pkgdesc="Fork of the popular zip manipulation library found in the zlib distribution."
+pkgver=3.0.2.r0.gbc93e40
pkgrel=1
arch=('x86_64')
-license=('custom')
+license=('zlib')
url="https://github.com/nmoinvaz/minizip"
depends=('glibc' 'libbsd' 'zlib')
makedepends=('git' 'cmake')
-source=("git+https://github.com/nmoinvaz/minizip.git#commit=7bdfbf4"
- "soversion.patch"
- "project_name.patch"
- "pc.patch")
-sha256sums=('SKIP'
- '3a648c48b9af7536e03c13327bd2f680a297fc629045fd904e344674971f3569'
- '3268ec716b89004bbc8124b3213c3bc0d15289d7771bbac82cd4c6694e390b79'
- 'd45977c36a6c1b2eefbf39d829be8753cecd3d8910d1926ad842359da3b9a869')
+conflicts=('minizip' 'minizip-ng' 'minizip-git')
+provides=('minizip' 'minizip-ng' 'minizip-git')
+source=("git+https://github.com/zlib-ng/minizip-ng")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}-ng
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
- cd ${srcdir}/${_pkgname}
- patch -p1 < ../soversion.patch
- patch -p1 < ../project_name.patch
- patch -p1 < ../pc.patch
+ cd ${srcdir}/${_pkgname}-ng
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
}
build() {
- cd ${srcdir}/${_pkgname}
+ cd ${srcdir}/${_pkgname}-ng/build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=ON \
- -DCMAKE_BUILD_TYPE=Release .
+ -DCMAKE_INSTALL_INCLUDEDIR=/usr/include/minizip \
+ -DCMAKE_BUILD_TYPE=Release ..
make
}
package() {
- cd ${_pkgname}
+ cd ${srcdir}/${_pkgname}-ng/build
make DESTDIR="${pkgdir}" install
+ install -D -m644 "${srcdir}/${_pkgname}-ng/LICENSE" "${pkgdir}/usr/share/licenses/minizip/LICENSE"
}
diff --git a/pc.patch b/pc.patch
deleted file mode 100644
index 767550401250..000000000000
--- a/pc.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/minizip.pc.cmakein b/minizip.pc.cmakein
-index bacb18a..22fa1ea 100644
---- a/minizip.pc.cmakein
-+++ b/minizip.pc.cmakein
-@@ -4,10 +4,10 @@ libdir=@INSTALL_LIB_DIR@
- sharedlibdir=@INSTALL_LIB_DIR@
- includedir=@INSTALL_INC_DIR@
-
--Name: minizip
-+Name: minizip2
- Description: Minizip zip file manipulation library
- Version: @VERSION@
-
- Requires: zlib
--Libs: -L${libdir} -L${sharedlibdir} -lminizip
-+Libs: -L${libdir} -L${sharedlibdir} -lminizip2
- Cflags: -I${includedir}
diff --git a/project_name.patch b/project_name.patch
deleted file mode 100644
index 377e51b68e61..000000000000
--- a/project_name.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f98a4e2..55ba79d 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -45,10 +45,10 @@ if(USE_ZLIB)
- add_definitions(-DHAVE_ZLIB)
- endif()
-
--set(MINIZIP_PC ${CMAKE_CURRENT_BINARY_DIR}/minizip.pc)
-+set(MINIZIP_PC ${CMAKE_CURRENT_BINARY_DIR}/minizip2.pc)
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/minizip.pc.cmakein ${MINIZIP_PC} @ONLY)
-
--set(PROJECT_NAME libminizip)
-+set(PROJECT_NAME libminizip2)
-
- set(MINIZIP_SRC
- mz_os.c
diff --git a/soversion.patch b/soversion.patch
deleted file mode 100644
index 0530346293db..000000000000
--- a/soversion.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f98a4e2..b2a0ea8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -32,6 +32,9 @@ set(INSTALL_CMAKE_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/minizip CACHE PATH "Installa
-
- set(VERSION "2.3.3")
-
-+# Minizip library SOVERSION
-+set(SOVERSION "2")
-+
- # Set cmake debug postfix to d
- set(CMAKE_DEBUG_POSTFIX "d")
-
-@@ -328,6 +331,8 @@ if (MINGW AND BUILD_SHARED_LIBS)
- set_target_properties(${PROJECT_NAME} PROPERTIES ARCHIVE_OUTPUT_NAME "minizip")
- endif ()
-
-+set_target_properties(${PROJECT_NAME} PROPERTIES VERSION ${VERSION} SOVERSION ${SOVERSION})
-+
- set_target_properties(${PROJECT_NAME} PROPERTIES LINKER_LANGUAGE C PREFIX ""
- POSITION_INDEPENDENT_CODE 1)
- if(USE_ZLIB)