summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas2023-12-17 18:41:38 +0100
committerJonas2023-12-17 18:41:38 +0100
commitb5d17e80256ac4e97a3ef83e3b798ec1328385bc (patch)
tree8faecd3a1166fc79bd62e0268af24d3164ec7a7e
downloadaur-b5d17e80256ac4e97a3ef83e3b798ec1328385bc.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b1e2ff95bc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = minorg
+ pkgdesc = Neorg related tool to convert Pandoc json to norg written in the Nim language
+ pkgver = 2.4.5
+ pkgrel = 1
+ url = https://github.com/pysan3/minorg
+ arch = x86_64
+ license = GPL
+ source = https://github.com/pysan3/minorg/releases/download/v2.4.5/minorg-linux_x64.tar.gz
+ sha256sums = 8242b74a5f91a40aa028aa41906531f87e004fb48f1437a0122c842e3067cb6e
+
+pkgname = minorg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72ebda4ab39b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: HyperTTP <jonas10bork at gmail dot com>
+
+pkgname=minorg
+pkgver=2.4.5
+pkgrel=1
+pkgdesc="Neorg related tool to convert Pandoc json to norg written in the Nim language"
+arch=('x86_64')
+url="https://github.com/pysan3/minorg"
+license=('GPL')
+changelog=
+source=("https://github.com/pysan3/$pkgname/releases/download/v$pkgver/$pkgname-linux_x64.tar.gz")
+# sha sums can be generated using `makepkg -g`
+sha256sums=('8242b74a5f91a40aa028aa41906531f87e004fb48f1437a0122c842e3067cb6e')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mv "$pkgname" "$pkgdir/usr/bin"
+}
+