summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuche12021-11-09 01:20:30 +0200
committerkuche12021-11-09 01:20:30 +0200
commitfb85a15f626a04825c845204db17c7f2e15707ca (patch)
tree1e47ec04e164d06f00e9ad204da9f7f90bd970e3
downloadaur-fb85a15f626a04825c845204db17c7f2e15707ca.tar.gz
fc
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d8266d77ba0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = minq_xvideos-git
+ pkgdesc = Watch xvideos in your terminal! Undesirable videos can be blocked!
+ pkgver = r13.d983a5287e2bb755d0410ce54b3ca2e7160aab46
+ pkgrel = 1
+ url = https://github.com/kuche1/minq_xvideos.git
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = python-beautifulsoup4
+ depends = viu
+ depends = mplayer
+ depends = yt-dlp
+ provides = minq_xvideos
+ source = git+https://github.com/kuche1/minq_xvideos.git
+ md5sums = SKIP
+
+pkgname = minq_xvideos-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c47cdc024d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=minq_xvideos-git
+pkgver=r13.d983a5287e2bb755d0410ce54b3ca2e7160aab46
+pkgrel=1
+epoch=
+pkgdesc="Watch xvideos in your terminal! Undesirable videos can be blocked!"
+arch=(x86_64 i686)
+url="https://github.com/kuche1/minq_xvideos.git"
+license=('GPL')
+groups=()
+depends=(python python-beautifulsoup4 viu mplayer yt-dlp)
+makedepends=(git)
+checkdepends=()
+optdepends=()
+provides=(minq_xvideos)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse HEAD)"
+}
+
+check() {
+ cd "minq_xvideos"
+ python3 --version
+}
+
+package() {
+ cd "minq_xvideos"
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ cp -rf * "${pkgdir}/opt/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ mkdir -p "${pkgdir}/usr/bin/"
+ ln -s "/opt/${pkgname}/minq_xvideos.py" "${pkgdir}/usr/bin/minq_xvideos"
+}