summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFaustino Aguilar2018-06-07 19:32:49 -0500
committerFaustino Aguilar2018-06-07 19:32:49 -0500
commited16ff4e67cfd6d862f72a675743ba6d95b7b38c (patch)
tree636575587d2de2a04d3b3a0524c69dde31c8b128
downloadaur-ed16ff4e67cfd6d862f72a675743ba6d95b7b38c.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore8
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD20
-rw-r--r--README.md17
5 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9228be0dde64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mint
+ pkgdesc = A is a refreshing language for the front-end web
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/mint-lang/mint
+ arch = x86_64
+ license = MIT
+ noextract = mint-0.0.3-linux
+ source = https://github.com/mint-lang/mint/releases/download/0.0.3/mint-0.0.3-linux
+ sha256sums = 8d54aeba208cda5e5d185b4b651a62ac87dade006873e8a0bb29081fe356558c
+
+pkgname = mint
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5bd19b8ee78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!PKGBUILD
+!*.install
+!*.sysusers
+!.SRCINFO
+!LICENSE
+!README.md \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..110d5287360a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2017 Amber Team
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c03106d959e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Faustino Aguilar <faustinoaq.github.io>
+pkgrel=1
+pkgname=mint
+pkgver=0.0.3
+pkgdesc="A is a refreshing language for the front-end web"
+arch=(x86_64)
+url='https://github.com/mint-lang/mint'
+source=("https://github.com/mint-lang/mint/releases/download/$pkgver/mint-$pkgver-linux")
+sha256sums=('8d54aeba208cda5e5d185b4b651a62ac87dade006873e8a0bb29081fe356558c')
+noextract=("mint-$pkgver-linux")
+license=('MIT')
+
+pre_install() {
+ wget https://raw.githubusercontent.com/mint-lang/mint/master/LICENSE
+}
+
+package() {
+ install -Dm755 "mint-$pkgver-linux" "$pkgdir/usr/bin/mint"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/mint/LICENSE
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..033b2e36264b
--- /dev/null
+++ b/README.md
@@ -0,0 +1,17 @@
+# AUR package for Mint Lang
+
+[Mint](https://www.mint-lang.com/) is a refreshing language for the front-end web.
+
+Execute it before publish a new version of mint:
+
+```
+makepkg --printsrcinfo > .SRCINFO
+```
+
+This package is avaliable on [AUR](https://aur.archlinux.org/packages/mint/)
+
+Install this package using:
+
+```
+yaourt -S mint-lang
+```