summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authord1ceward2020-04-07 10:05:02 +0200
committerd1ceward2020-04-07 10:05:02 +0200
commitf757950bb82af60483ea7ed6748b49e1741e0a6e (patch)
tree07b99267238c35cee922aeae2e4820021dccd9ee
parent3060ef4fcf77680ca36e0201a98628fb367adeec (diff)
downloadaur-f757950bb82af60483ea7ed6748b49e1741e0a6e.tar.gz
upgpkg: mint 0.9.0-2
-rwxr-xr-x.SRCINFO4
-rw-r--r--LICENSE29
-rwxr-xr-xPKGBUILD9
3 files changed, 37 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b39f0b3a3105..8b8d3d4d7664 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = mint
pkgdesc = A refreshing language for the front-end web
pkgver = 0.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mint-lang/mint
arch = x86_64
license = BSD
noextract = mint-0.9.0-linux
source = https://github.com/mint-lang/mint/releases/download/0.9.0/mint-0.9.0-linux
+ source = LICENSE
sha256sums = a6a7ab69e2c4a9ef9f60a81f807eac24aed4a62408a6a6a47a6a66f2c6728187
+ sha256sums = 6b4ecb1a9202a35540d0405ddd88439bb4644a127afc02ee26428ca5d5c0bd9f
pkgname = mint
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1114ba51bbcd
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+BSD 3-Clause License
+
+Copyright (c) 2018, Gusztáv Szikszai
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+* Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index e98faef71fc2..202689d141bc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,18 @@
pkgname=mint
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='A refreshing language for the front-end web'
arch=('x86_64')
url='https://github.com/mint-lang/mint'
-source=("https://github.com/mint-lang/mint/releases/download/${pkgver}/mint-${pkgver}-linux")
-sha256sums=('a6a7ab69e2c4a9ef9f60a81f807eac24aed4a62408a6a6a47a6a66f2c6728187')
+source=("https://github.com/mint-lang/mint/releases/download/${pkgver}/mint-${pkgver}-linux"
+ 'LICENSE')
+sha256sums=('a6a7ab69e2c4a9ef9f60a81f807eac24aed4a62408a6a6a47a6a66f2c6728187'
+ '6b4ecb1a9202a35540d0405ddd88439bb4644a127afc02ee26428ca5d5c0bd9f')
noextract=("mint-${pkgver}-linux")
license=('BSD')
package() {
- wget -q "https://raw.githubusercontent.com/mint-lang/mint/master/LICENSE"
install -Dm755 "mint-${pkgver}-linux" "${pkgdir}/usr/bin/mint"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/mint/LICENSE"
}