aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Pesch2022-12-16 16:17:19 +0100
committerMarkus Pesch2022-12-16 16:18:01 +0100
commit91d6938d530a4a64f6cb5097cd76cb842cd4d863 (patch)
tree1edff3ac358281ac684351ef4b1bec89327d7642
parentb78432ece412990f15cbb0e9c40c3e264574ef87 (diff)
downloadaur-91d6938d530a4a64f6cb5097cd76cb842cd4d863.tar.gz
fix(ci): init drone
-rw-r--r--.drone.yml55
-rw-r--r--.gitignore3
-rw-r--r--README.md1
3 files changed, 58 insertions, 1 deletions
diff --git a/.drone.yml b/.drone.yml
new file mode 100644
index 000000000000..8179213ff87c
--- /dev/null
+++ b/.drone.yml
@@ -0,0 +1,55 @@
+---
+kind: pipeline
+type: kubernetes
+name: linter
+
+platform:
+ os: linux
+ arch: amd64
+
+steps:
+- name: markdown lint
+ commands:
+ - markdownlint *.md
+ image: docker.io/volkerraschek/markdownlint:0.32.1
+ resources:
+ limits:
+ cpu: 150
+ memory: 150M
+
+- name: sync
+ image: appleboy/drone-git-push
+ environment:
+ GIT_PUSH_SSH_KEY:
+ from_secret: aur_ssh_key
+ settings:
+ branch: master
+ remote: ssh://aur@aur.archlinux.org/mint-backgrounds.git
+ force: false
+
+- name: email-notification
+ environment:
+ SMTP_FROM_ADDRESS:
+ from_secret: smtp_from_address
+ SMTP_FROM_NAME:
+ from_secret: smtp_from_name
+ SMTP_HOST:
+ from_secret: smtp_host
+ SMTP_USERNAME:
+ from_secret: smtp_username
+ SMTP_PASSWORD:
+ from_secret: smtp_password
+ image: docker.io/volkerraschek/drone-email:0.1.1
+ resources:
+ limits:
+ cpu: 150
+ memory: 150M
+ when:
+ status:
+ - changed
+ - failure
+
+trigger:
+ event:
+ exclude:
+ - tag \ No newline at end of file
diff --git a/.gitignore b/.gitignore
index e4f3cb584247..a70f9f43a17e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
*
-!PKGBUILD
+!.drone.yml
!.gitignore
!.editorconfig
!.SRCINFO
+!PKGBUILD
!README.md
diff --git a/README.md b/README.md
index c23b58997d01..5aa65016394f 100644
--- a/README.md
+++ b/README.md
@@ -4,6 +4,7 @@
[![https://img.shields.io/aur/license/mint-backgrounds](https://img.shields.io/aur/license/mint-backgrounds)](https://aur.archlinux.org/packages/mint-backgrounds)
[![https://img.shields.io/aur/maintainer/mint-backgrounds](https://img.shields.io/aur/maintainer/mint-backgrounds)](https://aur.archlinux.org/packages/mint-backgrounds)
[![https://img.shields.io/aur/last-modified/mint-backgrounds](https://img.shields.io/aur/last-modified/mint-backgrounds)](https://aur.archlinux.org/packages/mint-backgrounds)
+[![Build Status](https://drone.cryptic.systems/api/badges/volker.raschek/mint-backgrounds-pkg/status.svg)](https://drone.cryptic.systems/volker.raschek/mint-backgrounds-pkg)
This repository contains the source code to build the Arch Linux package
`mint-backgrounds`.