aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Pesch2023-12-02 13:52:11 +0100
committerMarkus Pesch2023-12-02 13:52:11 +0100
commite9ebff48a163ee9914972a9d2af478a11e57cdb3 (patch)
tree842574b38789c2678d660cd900665523eb3c9b44
parent6e18aa5165e8a7692e0ecf7f5da7d81db7805b1d (diff)
downloadaur-e9ebff48a163ee9914972a9d2af478a11e57cdb3.tar.gz
fix(ci): init
-rw-r--r--.drone.yml97
-rw-r--r--.editorconfig12
-rw-r--r--.gitignore10
-rw-r--r--.markdownlint.yaml145
-rw-r--r--README.md62
-rw-r--r--renovate.json17
6 files changed, 338 insertions, 5 deletions
diff --git a/.drone.yml b/.drone.yml
new file mode 100644
index 000000000000..dfc462a34294
--- /dev/null
+++ b/.drone.yml
@@ -0,0 +1,97 @@
+---
+kind: pipeline
+type: kubernetes
+name: linter
+
+clone:
+ disable: true
+
+steps:
+- name: clone
+ image: git.cryptic.systems/volker.raschek/git:1.3.1
+
+- name: markdown lint
+ commands:
+ - markdownlint *.md
+ image: git.cryptic.systems/volker.raschek/markdownlint:0.37.0
+ resources:
+ limits:
+ cpu: 150
+ memory: 150M
+
+- name: email-notification
+ environment:
+ SMTP_FROM_ADDRESS:
+ from_secret: smtp_from_address
+ SMTP_FROM_NAME:
+ from_secret: smtp_from_name
+ SMTP_HOST:
+ from_secret: smtp_host
+ SMTP_USERNAME:
+ from_secret: smtp_username
+ SMTP_PASSWORD:
+ from_secret: smtp_password
+ image: git.cryptic.systems/volker.raschek/drone-email:0.1.5
+ resources:
+ limits:
+ cpu: 150
+ memory: 150M
+ when:
+ status:
+ - changed
+ - failure
+
+trigger:
+ event:
+ exclude:
+ - tag
+
+---
+kind: pipeline
+type: kubernetes
+name: sync-to-aur.archlinux.org
+
+clone:
+ disable: true
+
+steps:
+- name: clone
+ image: git.cryptic.systems/volker.raschek/git:1.3.1
+
+- name: git-push
+ image: docker.io/appleboy/drone-git-push:1.0.6
+ settings:
+ branch: master
+ remote: ssh://aur@aur.archlinux.org/mint-backgrounds-helena.git
+ force: false
+ commit: false
+ ssh_key:
+ from_secret: aur_ssh_key
+
+- name: email-notification
+ environment:
+ SMTP_FROM_ADDRESS:
+ from_secret: smtp_from_address
+ SMTP_FROM_NAME:
+ from_secret: smtp_from_name
+ SMTP_HOST:
+ from_secret: smtp_host
+ SMTP_USERNAME:
+ from_secret: smtp_username
+ SMTP_PASSWORD:
+ from_secret: smtp_password
+ image: git.cryptic.systems/volker.raschek/drone-email:0.1.5
+ resources:
+ limits:
+ cpu: 150
+ memory: 150M
+ when:
+ status:
+ - changed
+ - failure
+
+trigger:
+ event:
+ - tag
+ repo:
+ - volker.raschek/mint-backgrounds-helena-pkg \ No newline at end of file
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..1166a4a0a372
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,12 @@
+# EditorConfig is awesome: https://EditorConfig.org
+
+# top-most EditorConfig file
+root = true
+
+[*]
+indent_style = space
+indent_size = 2
+end_of_line = lf
+charset = utf-8
+trim_trailing_whitespace = true
+insert_final_newline = false \ No newline at end of file
diff --git a/.gitignore b/.gitignore
index 3814e4105a02..7d4ec31118d4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
-*
-!PKGBUILD
-!.gitignore
-!.editorconfig
-!.SRCINFO
+pkg
+src
+*tar.gz
+*tar.zst
+*tar.zst.sig \ No newline at end of file
diff --git a/.markdownlint.yaml b/.markdownlint.yaml
new file mode 100644
index 000000000000..54c8c831b7bf
--- /dev/null
+++ b/.markdownlint.yaml
@@ -0,0 +1,145 @@
+# markdownlint YAML configuration
+# https://github.com/DavidAnson/markdownlint/blob/main/schema/.markdownlint.yaml
+
+# Default state for all rules
+default: true
+
+# Path to configuration file to extend
+extends: null
+
+# MD003/heading-style/header-style - Heading style
+MD003:
+ # Heading style
+ style: "atx"
+
+# MD004/ul-style - Unordered list style
+MD004:
+ style: "dash"
+
+# MD007/ul-indent - Unordered list indentation
+MD007:
+ # Spaces for indent
+ indent: 2
+ # Whether to indent the first level of the list
+ start_indented: false
+
+# MD009/no-trailing-spaces - Trailing spaces
+MD009:
+ # Spaces for line break
+ br_spaces: 2
+ # Allow spaces for empty lines in list items
+ list_item_empty_lines: false
+ # Include unnecessary breaks
+ strict: false
+
+# MD010/no-hard-tabs - Hard tabs
+MD010:
+ # Include code blocks
+ code_blocks: true
+
+# MD012/no-multiple-blanks - Multiple consecutive blank lines
+MD012:
+ # Consecutive blank lines
+ maximum: 1
+
+# MD013/line-length - Line length
+MD013:
+ # Number of characters
+ line_length: 120
+ # Number of characters for headings
+ heading_line_length: 120
+ # Number of characters for code blocks
+ code_block_line_length: 120
+ # Include code blocks
+ code_blocks: false
+ # Include tables
+ tables: false
+ # Include headings
+ headings: true
+ # Include headings
+ headers: true
+ # Strict length checking
+ strict: false
+ # Stern length checking
+ stern: false
+
+# MD022/blanks-around-headings/blanks-around-headers - Headings should be surrounded by blank lines
+MD022:
+ # Blank lines above heading
+ lines_above: 1
+ # Blank lines below heading
+ lines_below: 1
+
+# MD024/no-duplicate-heading/no-duplicate-header - Multiple headings with the same content
+MD024:
+ # Only check sibling headings
+ allow_different_nesting: true
+
+# MD025/single-title/single-h1 - Multiple top-level headings in the same document
+MD025:
+ # Heading level
+ level: 1
+ # RegExp for matching title in front matter
+ front_matter_title: "^\\s*title\\s*[:=]"
+
+# MD026/no-trailing-punctuation - Trailing punctuation in heading
+MD026:
+ # Punctuation characters
+ punctuation: ".,;:!。,;:!"
+
+# MD029/ol-prefix - Ordered list item prefix
+MD029:
+ # List style
+ style: "one_or_ordered"
+
+# MD030/list-marker-space - Spaces after list markers
+MD030:
+ # Spaces for single-line unordered list items
+ ul_single: 1
+ # Spaces for single-line ordered list items
+ ol_single: 1
+ # Spaces for multi-line unordered list items
+ ul_multi: 1
+ # Spaces for multi-line ordered list items
+ ol_multi: 1
+
+# MD033/no-inline-html - Inline HTML
+MD033:
+ # Allowed elements
+ allowed_elements: []
+
+# MD035/hr-style - Horizontal rule style
+MD035:
+ # Horizontal rule style
+ style: "---"
+
+# MD036/no-emphasis-as-heading/no-emphasis-as-header - Emphasis used instead of a heading
+MD036:
+ # Punctuation characters
+ punctuation: ".,;:!?。,;:!?"
+
+# MD041/first-line-heading/first-line-h1 - First line in a file should be a top-level heading
+MD041:
+ # Heading level
+ level: 1
+ # RegExp for matching title in front matter
+ front_matter_title: "^\\s*title\\s*[:=]"
+
+# MD044/proper-names - Proper names should have the correct capitalization
+MD044:
+ # List of proper names
+ names:
+ - Arch Linux
+ - Linux Mint
+ # Include code blocks
+ code_blocks: false
+
+# MD046/code-block-style - Code block style
+MD046:
+ # Block style
+ style: "fenced"
+
+# MD048/code-fence-style - Code fence style
+MD048:
+ # Code fence syle
+ style: "backtick" \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..c2a305a7ad49
--- /dev/null
+++ b/README.md
@@ -0,0 +1,62 @@
+# mint-backgrounds-julia
+
+![AUR version](https://img.shields.io/aur/version/mint-backgrounds-julia?label=AUR)
+[![Build Status](https://drone.cryptic.systems/api/badges/volker.raschek/mint-backgrounds-julia-pkg/status.svg)](https://drone.cryptic.systems/volker.raschek/mint-backgrounds-julia-pkg)
+![AUR votes](https://img.shields.io/aur/votes/mint-backgrounds-julia)
+
+This repository contains build files to build the Arch Linux package `mint-backgrounds-julia`. Instead of building the
+package yourself, it can also be obtained from the following private repository. More detailed are described
+[here](#obtaining-pre-built-packages-from-a-repository).
+
+## Build
+
+Clone this repository and use `makepkg` to build the package by yourself. For example:
+
+```bash
+git clone https://aur.archlinux.org/mint-backgrounds-julia.git
+cd mint-backgrounds-julia
+makepkg
+```
+
+## Yay
+
+The build files are also available via AUR and can be installed via an AUR helper like `yay`.
+
+```bash
+yay --sync --aur mint-backgrounds-julia
+```
+
+## Obtaining pre-built packages from a repository
+
+Instead of building the packages locally, it is also possible to configure an additional repository to install the
+package directly via `pacman`. The following commands are used to create the repository, configure the GPG key to verify
+the packages and install the package:
+
+```bash
+# Create drop-in directory
+sudo mkdir --parents /etc/pacman.d/repos
+
+# Create configuration of the repository 'volker.raschek'
+sudo tee /etc/pacman.d/repos/volker.raschek.conf > /dev/null <<'EOF'
+[volker.raschek]
+SigLevel = PackageRequired TrustedOnly
+Include = /etc/pacman.d/repos/volker.raschek.list
+EOF
+
+# Create mirror list of the repository 'volker.raschek'
+sudo tee /etc/pacman.d/repos/volker.raschek.list > /dev/null <<'EOF'
+Server = https://aur.cryptic.systems/$repo/$arch
+EOF
+
+# Import gpg key of the repository 'volker.raschek'
+sudo pacman-key --keyserver hkps://keys.openpgp.org --recv-keys 9B146D11A9ED6CA7E279EB1A852BCC170D81A982
+
+# Extend existing pacman configuration of the repository 'volker.raschek'
+sudo echo "Include = /etc/pacman.d/repos/*.conf" >> /etc/pacman.conf
+
+# Update pacman cache
+sudo pacman --sync --refresh
+
+# Install the package and receive updates directly via pacman :)
+sudo pacman --sync mint-backgrounds-julia
+```
diff --git a/renovate.json b/renovate.json
new file mode 100644
index 000000000000..0eb214cf1026
--- /dev/null
+++ b/renovate.json
@@ -0,0 +1,17 @@
+{
+ "$schema": "https://docs.renovatebot.com/renovate-schema.json",
+ "assignees": [ "volker.raschek" ],
+ "automergeStrategy": "merge-commit",
+ "automergeType": "pr",
+ "labels": [ "renovate" ],
+ "packageRules": [
+ {
+ "addLabels": [ "renovate/droneci", "renovate/automerge" ],
+ "automerge": true,
+ "matchManagers": "droneci",
+ "matchUpdateTypes": [ "minor", "patch"]
+ }
+ ],
+ "rebaseLabel": "renovate/rebase",
+ "rebaseWhen": "behind-base-branch"
+}