summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormarkus2020-12-30 10:46:11 +0100
committermarkus2020-12-30 10:46:11 +0100
commitee076701b12b12b59142241a958f4a7748aa8a99 (patch)
tree822a9da2c0d7f74f309a1527243e0a0641d330ba
downloadaur-ee076701b12b12b59142241a958f4a7748aa8a99.tar.gz
Initial Commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a13e8ef1d7ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mint-backgrounds-ulyssa
+ pkgdesc = The backgrounds included in Linux Mint 20.1 Ulyssa
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://packages.linuxmint.com/pool/main/m/mint-backgrounds-ulyssa
+ arch = any
+ license = Various
+ source = http://packages.linuxmint.com/pool/main/m/mint-backgrounds-ulyssa/mint-backgrounds-ulyssa_1.1.tar.gz
+ sha256sums = b1abd4d0fe894a5fdf8c24dd592a4a2ffb7d964888ef3f0dad65526e3a5776af
+
+pkgname = mint-backgrounds-ulyssa
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3814e4105a02
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.gitignore
+!.editorconfig
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45a79da27973
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Markus Pesch <markus.pesch@cryptic.systems>
+
+pkgname=mint-backgrounds-ulyssa
+pkgver=1.1
+pkgrel=1
+pkgdesc="The backgrounds included in Linux Mint 20.1 Ulyssa"
+license=('Various')
+arch=('any')
+url="http://packages.linuxmint.com/pool/main/m/${pkgname}"
+source=("${url}/${pkgname}_$pkgver.tar.gz")
+sha256sums=('b1abd4d0fe894a5fdf8c24dd592a4a2ffb7d964888ef3f0dad65526e3a5776af')
+
+package() {
+ mkdir --parents ${pkgdir}/usr/share/backgrounds/linuxmint-ulyssa
+ mkdir --parents ${pkgdir}/usr/share/{cinnamon-background-properties,gnome-background-properties,mate-background-properties}
+
+ cp --archive ${srcdir}/${pkgname}/backgrounds/linuxmint-ulyssa ${pkgdir}/usr/share/backgrounds
+ cp --archive ${srcdir}/${pkgname}/cinnamon-background-properties/* ${pkgdir}/usr/share/cinnamon-background-properties
+ cp --archive ${srcdir}/${pkgname}/gnome-background-properties/* ${pkgdir}/usr/share/gnome-background-properties
+ cp --archive ${srcdir}/${pkgname}/mate-background-properties/* ${pkgdir}/usr/share/mate-background-properties
+}