summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Pesch2022-01-11 09:00:47 +0100
committerMarkus Pesch2022-01-11 09:00:47 +0100
commit4cd03d702538c00e0fb51b95c30cdef9aecd82bf (patch)
treec38ffcc0991a947e0f5d7ae58596019a254cdb13
downloadaur-4cd03d702538c00e0fb51b95c30cdef9aecd82bf.tar.gz
Initial Commit
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a67d4db172a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = mint-backgrounds-una
+ pkgdesc = The backgrounds included in Linux Mint 20.3 una
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://packages.linuxmint.com/pool/main/m/mint-backgrounds-una
+ arch = any
+ license = Various
+ source = http://packages.linuxmint.com/pool/main/m/mint-backgrounds-una/mint-backgrounds-una_1.1.tar.gz
+ sha256sums = 42a8af8c7f18bb83743ba31ee6c2d74ba9328bbac2d28399a7218991400a6e9c
+
+pkgname = mint-backgrounds-una
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3814e4105a02
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.gitignore
+!.editorconfig
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11952f17a5b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Markus Pesch <markus.pesch@cryptic.systems>
+
+pkgname=mint-backgrounds-una
+pkgver=1.1
+pkgrel=1
+pkgdesc="The backgrounds included in Linux Mint 20.3 una"
+license=('Various')
+arch=('any')
+url="http://packages.linuxmint.com/pool/main/m/${pkgname}"
+source=("${url}/${pkgname}_$pkgver.tar.gz")
+sha256sums=('42a8af8c7f18bb83743ba31ee6c2d74ba9328bbac2d28399a7218991400a6e9c')
+
+package() {
+ mkdir --parents ${pkgdir}/usr/share/backgrounds/linuxmint-una
+ mkdir --parents ${pkgdir}/usr/share/{cinnamon-background-properties,gnome-background-properties,mate-background-properties}
+
+ cp --archive ${srcdir}/${pkgname}/backgrounds/linuxmint-una ${pkgdir}/usr/share/backgrounds
+ cp --archive ${srcdir}/${pkgname}/cinnamon-background-properties/* ${pkgdir}/usr/share/cinnamon-background-properties
+ cp --archive ${srcdir}/${pkgname}/gnome-background-properties/* ${pkgdir}/usr/share/gnome-background-properties
+ cp --archive ${srcdir}/${pkgname}/mate-background-properties/* ${pkgdir}/usr/share/mate-background-properties
+}