summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseantum2022-06-14 23:33:33 +0200
committerseantum2022-06-14 23:33:33 +0200
commitbbc3b3c145f498f2bdaea484352975e1ff6da62f (patch)
tree08c676037b2f6a5a7cd1a3df41d94e2252a6ee7a
downloadaur-bbc3b3c145f498f2bdaea484352975e1ff6da62f.tar.gz
initial
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bcac308283c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = mint-backgrounds-vanessa
+ pkgdesc = The backgrounds included in Linux Mint 21 Vanessa
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://packages.linuxmint.com/pool/main/m/mint-backgrounds-vanessa
+ arch = any
+ license = Various
+ source = http://packages.linuxmint.com/pool/main/m/mint-backgrounds-vanessa/mint-backgrounds-vanessa_1.0.tar.gz
+ sha256sums = 8e6634e8ad672893fe39d51be0809367fd9421917ccaa36a6fced1f6301c7558
+
+pkgname = mint-backgrounds-vanessa
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71aeca3dd427
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Seantum <tsiegele AT gmx DOT at>
+# Contributor: Markus Pesch <markus.pesch@cryptic.systems>
+
+pkgname=mint-backgrounds-vanessa
+pkgver=1.0
+pkgrel=1
+pkgdesc="The backgrounds included in Linux Mint 21 Vanessa"
+license=('Various')
+arch=('any')
+url="http://packages.linuxmint.com/pool/main/m/${pkgname}"
+source=("${url}/${pkgname}_$pkgver.tar.gz")
+sha256sums=('8e6634e8ad672893fe39d51be0809367fd9421917ccaa36a6fced1f6301c7558')
+
+package() {
+ mkdir --parents ${pkgdir}/usr/share/backgrounds/linuxmint-vanessa
+ mkdir --parents ${pkgdir}/usr/share/{cinnamon-background-properties,gnome-background-properties,mate-background-properties}
+
+ cp --archive ${srcdir}/${pkgname}/backgrounds/linuxmint-vanessa ${pkgdir}/usr/share/backgrounds
+ cp --archive ${srcdir}/${pkgname}/cinnamon-background-properties/* ${pkgdir}/usr/share/cinnamon-background-properties
+ cp --archive ${srcdir}/${pkgname}/gnome-background-properties/* ${pkgdir}/usr/share/gnome-background-properties
+ cp --archive ${srcdir}/${pkgname}/mate-background-properties/* ${pkgdir}/usr/share/mate-background-properties
+}
+