summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Pesch2023-06-23 09:01:30 +0200
committerMarkus Pesch2023-06-23 09:01:30 +0200
commit4d8a441a8340e794723da3ee4ed74c900a3f750f (patch)
tree579912118c1cf86c96182d8ed469dfc342f579ab
downloadaur-4d8a441a8340e794723da3ee4ed74c900a3f750f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..205f7fd9a3a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = mint-backgrounds-victoria
+ pkgdesc = The backgrounds included in Linux Mint 21.2 victoria
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://packages.linuxmint.com/pool/main/m/mint-backgrounds-victoria
+ arch = any
+ license = Various
+ source = http://packages.linuxmint.com/pool/main/m/mint-backgrounds-victoria/mint-backgrounds-victoria_1.2.tar.gz
+ sha256sums = a8de3ae8baae5f58d037f2f329d5ece087397ef1e2d2835245ec570304a367d5
+
+pkgname = mint-backgrounds-victoria
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3814e4105a02
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.gitignore
+!.editorconfig
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3726436df68e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Markus Pesch <markus.pesch@cryptic.systems>
+
+pkgname=mint-backgrounds-victoria
+pkgver=1.2
+pkgrel=1
+pkgdesc="The backgrounds included in Linux Mint 21.2 victoria"
+license=('Various')
+arch=('any')
+url="http://packages.linuxmint.com/pool/main/m/${pkgname}"
+source=("${url}/${pkgname}_$pkgver.tar.gz")
+sha256sums=('a8de3ae8baae5f58d037f2f329d5ece087397ef1e2d2835245ec570304a367d5')
+
+package() {
+ mkdir --parents ${pkgdir}/usr/share/backgrounds/linuxmint-victoria
+ mkdir --parents ${pkgdir}/usr/share/{cinnamon-background-properties,gnome-background-properties,mate-background-properties}
+
+ cp --archive ${srcdir}/${pkgname}/backgrounds/linuxmint-victoria ${pkgdir}/usr/share/backgrounds
+ cp --archive ${srcdir}/${pkgname}/cinnamon-background-properties/* ${pkgdir}/usr/share/cinnamon-background-properties
+ cp --archive ${srcdir}/${pkgname}/gnome-background-properties/* ${pkgdir}/usr/share/gnome-background-properties
+ cp --archive ${srcdir}/${pkgname}/mate-background-properties/* ${pkgdir}/usr/share/mate-background-properties
+}