summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhacker10242018-11-07 18:25:34 +1100
committerhacker10242018-11-07 18:25:34 +1100
commit0edda3cf2bcee38e7f5927a406cb59296cc48049 (patch)
treed150fb10cb40fb6361bca0f437b658889f1fc8ca
downloadaur-0edda3cf2bcee38e7f5927a406cb59296cc48049.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3bcff424d60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mint-themes-git
+ pkgdesc = Linux Mint themes
+ pkgver = 400.44239e7
+ pkgrel = 1
+ url = https://github.com/linuxmint/mint-themes
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = ruby-sass
+ provides = mint-themes
+ provides = mint-x-theme
+ provides = mint-y-theme
+ conflicts = mint-themes
+ conflicts = mint-x-theme
+ conflicts = mint-y-theme
+ source = mint-themes::git+https://github.com/linuxmint/mint-themes.git
+ sha256sums = SKIP
+
+pkgname = mint-themes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10682ec510fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: hacker1024 <joshleivenzon at outlook dot com>
+
+_pkgname=mint-themes
+pkgname=${_pkgname}-git
+pkgver=400.44239e7
+pkgrel=1
+pkgdesc="Linux Mint themes"
+arch=('any')
+url="https://github.com/linuxmint/mint-themes"
+license=('GPL3')
+makedepends=('git' 'ruby-sass')
+conflicts=("${_pkgname}" 'mint-x-theme' 'mint-y-theme')
+provides=("${_pkgname}" 'mint-x-theme' 'mint-y-theme')
+source=("${_pkgname}"::git+https://github.com/linuxmint/mint-themes.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ make
+ find "${srcdir}/${_pkgname}"/usr/share/themes -type f -name "metacity*xml" -exec sed -i 's:normal_dialog_style_set:normal_style_set:' {} \;
+}
+
+package() {
+ cp -aR --no-preserve=ownership "${srcdir}/${_pkgname}"/usr "${pkgdir}"
+}