summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortwa0222016-04-06 18:04:38 -0400
committertwa0222016-04-06 18:04:38 -0400
commitff541ad75ca077f242c96763e431b5f4ddb4af60 (patch)
tree73d0bd50653a1656b0d3b23310a70dcccd0785ad
downloadaur-ff541ad75ca077f242c96763e431b5f4ddb4af60.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--mint-y-icons.install15
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c28d1b9c1e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Apr 6 22:04:21 UTC 2016
+pkgbase = mint-y-icons-git
+ pkgdesc = New icons from LinuxMint 18 inspired by the Moka icon set
+ pkgver = 36.e8d97fe
+ pkgrel = 1
+ url = https://github.com/linuxmint/mint-y-icons
+ install = mint-y-icons.install
+ arch = any
+ license = GPL3
+ optdepends = mint-x-icons: Mint-Y inherits missing icons from Mint-X
+ provides = mint-y-icons
+ conflicts = mint-y-icons
+ options = optipng
+ source = mint-y-icons::git+https://github.com/linuxmint/mint-y-icons.git
+ sha256sums = SKIP
+
+pkgname = mint-y-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de96da40b728
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=mint-y-icons
+pkgname=${_pkgname}-git
+pkgver=36.e8d97fe
+pkgrel=1
+pkgdesc="New icons from LinuxMint 18 inspired by the Moka icon set"
+arch=('any')
+url="https://github.com/linuxmint/mint-y-icons"
+license=('GPL3')
+depends=()
+makedepends=()
+optdepends=("mint-x-icons: Mint-Y inherits missing icons from Mint-X")
+options=('optipng')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("${_pkgname}"::git+https://github.com/linuxmint/mint-y-icons.git)
+install="$_pkgname.install"
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+
+ cp -aR ./usr ${pkgdir}
+}
diff --git a/mint-y-icons.install b/mint-y-icons.install
new file mode 100644
index 000000000000..6621ffbbaf91
--- /dev/null
+++ b/mint-y-icons.install
@@ -0,0 +1,15 @@
+post_install() {
+ gtk-update-icon-cache -qtf /usr/share/icons/Mint-Y
+# for color in Aqua Blue Brown Dark Grey Orange Pink Purple Red Sand Teal Yellow; do
+# gtk-update-icon-cache -qtf /usr/share/icons/Mint-X-${color}
+# done
+ gdk-pixbuf-query-loaders --update-cache
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}