summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSantiago Burgos2024-05-14 11:04:14 -0600
committerSantiago Burgos2024-05-14 11:04:14 -0600
commit612a7133d10974c7e62e392db6041a734b5e754d (patch)
tree57249d2432200d1954fa4239be705b42f8a4d709
parent107363d373be4a305c22988f22e1566d79bc1196 (diff)
downloadaur-612a7133d10974c7e62e392db6041a734b5e754d.tar.gz
updated to version 1.6.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD42
2 files changed, 25 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 004c0271e8df..08e63e6e5c51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mintlocale
pkgdesc = Language and locale selection tool
- pkgver = 1.5.8
+ pkgver = 1.6.1
pkgrel = 1
url = http://packages.linuxmint.com/pool/main/m/mintlocale
arch = any
@@ -14,10 +14,10 @@ pkgbase = mintlocale
depends = python-cairo
depends = python-gobject
depends = xapp
- source = mintlocale-1.5.8.tar.xz::http://packages.linuxmint.com/pool/main/m/mintlocale/mintlocale_1.5.8.tar.xz
+ source = mintlocale-1.6.1.tar.xz::http://packages.linuxmint.com/pool/main/m/mintlocale/mintlocale_1.6.1.tar.xz
source = im_apt_check.patch
source = install_remove_apt_check.patch
- sha256sums = 50baecb9e5e4758a54c50caa301eeb027fb54e6ecac2fb1ac5cc3d487b6caa1f
+ sha256sums = 2b82b8981a7e33352587c7086b277d3c4e818766b110512e240d69ac962d72c5
sha256sums = 21778d62b28e677cfb8d7784c5b486ff373534de6e6fb5603e2c8bd268abef7b
sha256sums = 4b8bc562521564022ae657ce1db7c3170d4184f955150bd9e51b871c73f4a996
diff --git a/PKGBUILD b/PKGBUILD
index d13e49c24411..0bd426303261 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Manuel Hüsers <aur@huesers.de>
-# Maintainer: Sam Burgos < sam dot burgos1089 at gmail dot com >
+# Maintainer: Santiago Burgos <santiago.burgos1089@gmail.com>
+# Contributer: Manuel Hüsers <aur@huesers.de>
# Many options will remain here as leftovers in case the packaging in Github resumes once again
pkgname=mintlocale
-pkgver=1.5.8
+pkgver=1.6.1
pkgrel=1
pkgdesc="Language and locale selection tool"
arch=('any')
#url='https://github.com/linuxmint/mintlocale'
url="http://packages.linuxmint.com/pool/main/m/${pkgname}"
license=('GPL2')
-depends=('accountsservice'
+depends=(
+ 'accountsservice'
'gdk-pixbuf2'
'glib2'
'gtk3'
@@ -18,7 +19,8 @@ depends=('accountsservice'
'python'
'python-cairo'
'python-gobject'
- 'xapp')
+ 'xapp'
+)
#source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
# "im_apt_check.patch"
# "install_remove_apt_check.patch"
@@ -26,32 +28,32 @@ depends=('accountsservice'
source=("${pkgname}-${pkgver}.tar.xz::${url}/${pkgname}_${pkgver}.tar.xz"
"im_apt_check.patch"
"install_remove_apt_check.patch")
-sha256sums=('50baecb9e5e4758a54c50caa301eeb027fb54e6ecac2fb1ac5cc3d487b6caa1f'
+sha256sums=('2b82b8981a7e33352587c7086b277d3c4e818766b110512e240d69ac962d72c5'
'21778d62b28e677cfb8d7784c5b486ff373534de6e6fb5603e2c8bd268abef7b'
'4b8bc562521564022ae657ce1db7c3170d4184f955150bd9e51b871c73f4a996')
## Packaging via Linuxmint repository
prepare() {
- cd "${pkgname}"
+ cd "${pkgname}"
- # Remove the im desktop file and executable from this package,
- # this is done since input methods are handled differently on Arch
- rm -f 'usr/share/applications/mintlocale-im.desktop'
- rm -f 'usr/bin/mintlocale-im'
+ # Remove the im desktop file and executable from this package,
+ # this is done since input methods are handled differently on Arch
+ rm -f 'usr/share/applications/mintlocale-im.desktop'
+ rm -f 'usr/bin/mintlocale-im'
- #Added checking of APT in mintlocale so application can show proper configuration
- #Patching "im.py" file
- patch -Np1 -i ../im_apt_check.patch
- #Patching "install_remove.py" file
- patch -Np1 -i ../install_remove_apt_check.patch
- #Patching "mintlocale.py" file
- #patch -Np1 -i ../mintlocale_apt_check.patch
+ #Added checking of APT in mintlocale so application can show proper configuration
+ #Patching "im.py" file
+ patch -Np1 -i ../im_apt_check.patch
+ #Patching "install_remove.py" file
+ patch -Np1 -i ../install_remove_apt_check.patch
+ #Patching "mintlocale.py" file
+ #patch -Np1 -i ../mintlocale_apt_check.patch
}
package() {
- cd ${pkgname}
- cp -r usr "$pkgdir"
+ cd ${pkgname}
+ cp -r usr "$pkgdir"
}
## Packaging via Github