summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaire Farron2016-04-30 19:41:02 +0100
committerClaire Farron2016-04-30 19:41:02 +0100
commit9f478f0d959f6266ff398fba09a0066b43bdb5f9 (patch)
tree49c39f67b4b963eebbfcb766d8a623158ca92680
parent4ba37d45a20114a534d82c3d9a6d37c7bbd812ba (diff)
downloadaur-9f478f0d959f6266ff398fba09a0066b43bdb5f9.tar.gz
Update to 1.3.3..
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--apt_pkg.patch31
3 files changed, 22 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c30efbc8d49c..17f47d0c9ec2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 20:32:45 UTC 2016
+# Sat Apr 30 18:40:47 UTC 2016
pkgbase = mintlocale
pkgdesc = Locale selection for the Cinnamon Desktop
- pkgver = 1.3.1
+ pkgver = 1.3.3
pkgrel = 1
url = https://github.com/linuxmint/mintlocale
arch = any
license = GPL2
depends = python2-gobject
- source = http://packages.linuxmint.com/pool/main/m/mintlocale/mintlocale_1.3.1.tar.gz
+ source = http://packages.linuxmint.com/pool/main/m/mintlocale/mintlocale_1.3.3.tar.xz
source = apt_pkg.patch
- sha256sums = 2124bcc023cccd13ff53a9ab50e177f2d5616224ac63edb6a348809bb3b491d9
- sha256sums = d18b6ae1a699b5a31436bbaf2a18d96d64a54e33a6d5daa1c60dfb0250f2dbc2
+ sha256sums = e188e695b53667f0be746d6ab58ea24fa31771090e6ec77c64365591aa1703fd
+ sha256sums = b065dc500075a5648a4aa15c98b701af7816d3d0ee2822330635b5fe6740d116
pkgname = mintlocale
diff --git a/PKGBUILD b/PKGBUILD
index 57b646c88bbe..7b2a6da64ec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
# Contributor: Pedro Gabriel <pedrogabriel@dcc.ufmg.br>
pkgname=mintlocale
-pkgver=1.3.1
+pkgver=1.3.3
pkgrel=1
pkgdesc="Locale selection for the Cinnamon Desktop"
arch=('any')
url="https://github.com/linuxmint/mintlocale"
license=('GPL2')
depends=('python2-gobject')
-source=("http://packages.linuxmint.com/pool/main/m/mintlocale/mintlocale_$pkgver.tar.gz"
+source=("http://packages.linuxmint.com/pool/main/m/mintlocale/mintlocale_$pkgver.tar.xz"
"apt_pkg.patch")
-sha256sums=('2124bcc023cccd13ff53a9ab50e177f2d5616224ac63edb6a348809bb3b491d9'
- 'd18b6ae1a699b5a31436bbaf2a18d96d64a54e33a6d5daa1c60dfb0250f2dbc2')
+sha256sums=('e188e695b53667f0be746d6ab58ea24fa31771090e6ec77c64365591aa1703fd'
+ 'b065dc500075a5648a4aa15c98b701af7816d3d0ee2822330635b5fe6740d116')
prepare() {
diff --git a/apt_pkg.patch b/apt_pkg.patch
index 1397028f6ca9..7ad0a8fdbf0f 100644
--- a/apt_pkg.patch
+++ b/apt_pkg.patch
@@ -1,27 +1,22 @@
-diff --git /usr/lib/linuxmint/mintLocale/mintLocale.py /usr/lib/linuxmint/mintLocale/mintLocale.py
---- /usr/lib/linuxmint/mintLocale/mintLocale.py
-+++ /usr/lib/linuxmint/mintLocale/mintLocale.py
-This patch removes the options to Add/Remove Languages in Language Settings, as ArchLinux does not use apt (hence no apt_pkg option is available).
-index 990e39b..89267b5 100755
-@@ -14,7 +14,6 @@
- import ConfigParser
- import grp
- import locale
-- import apt
- import tempfile
- from subprocess import Popen
- except Exception, detail:
-@@ -396,7 +395,12 @@
- self.accountService = AccountsService.UserManager.get_default().get_user(current_user)
+--- /usr/lib/linuxmint/mintlocale/mintlocale.py 2016-04-30 19:32:16.650226256 +0100
++++ /usr/lib/linuxmint/mintlocale/mintlocale.py.new 2016-04-30 19:35:29.730222054 +0100
+@@ -13,7 +13,6 @@
+ import ConfigParser
+ import grp
+ import locale
+-import apt
+ import tempfile
+ import thread
+ from subprocess import Popen
+@@ -512,6 +511,11 @@
self.accountService.connect('notify::is-loaded', self.accountservice_ready)
self.accountService.connect('changed::', self.accountservice_changed)
--
-+
+
+ try:
+ import apt_pkg
+ except ImportError:
+ return
-+
++
groups = grp.getgrall()
for group in groups:
(name, pw, gid, mem) = group