summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaire Farron2015-06-11 13:50:19 +0100
committerClaire Farron2015-06-11 13:50:19 +0100
commiteb54cf21f99121973053a9e28ed0ddf64bc26713 (patch)
treeae9dd128f7d37e423f0b16999e07347aba2a3fca
downloadaur-eb54cf21f99121973053a9e28ed0ddf64bc26713.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rw-r--r--apt_pkg.patch27
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4f803f70cc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mintlocale
+ pkgdesc = Locale selection for the Cinnamon Desktop
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/linuxmint/mintlocale
+ arch = any
+ license = GPL2
+ depends = python2-gobject
+ source = http://packages.linuxmint.com/pool/main/m/mintlocale/mintlocale_1.2.2.tar.gz
+ source = apt_pkg.patch
+ sha256sums = 92050d3138954e2114aac4e75c1f927b40d52123ade4fdfbb3a8d6d25aaf37ec
+ sha256sums = d18b6ae1a699b5a31436bbaf2a18d96d64a54e33a6d5daa1c60dfb0250f2dbc2
+
+pkgname = mintlocale
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..350bc537abf0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer : Claire Farron <diesal3@googlemail.com>
+# Major Contributor : loqs (PKGBUILD, apt_pkg.patch)
+
+pkgname=mintlocale
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Locale selection for the Cinnamon Desktop"
+arch=('any')
+url="https://github.com/linuxmint/mintlocale"
+license=('GPL2')
+depends=('python2-gobject')
+source=("http://packages.linuxmint.com/pool/main/m/mintlocale/mintlocale_$pkgver.tar.gz"
+ "apt_pkg.patch")
+
+sha256sums=('92050d3138954e2114aac4e75c1f927b40d52123ade4fdfbb3a8d6d25aaf37ec'
+ 'd18b6ae1a699b5a31436bbaf2a18d96d64a54e33a6d5daa1c60dfb0250f2dbc2')
+
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ find -type f -print0 | xargs -0 sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+ patch -p1 -i ../apt_pkg.patch
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ cp -r --no-preserve=owner usr $pkgdir
+}
diff --git a/apt_pkg.patch b/apt_pkg.patch
new file mode 100644
index 000000000000..1397028f6ca9
--- /dev/null
+++ b/apt_pkg.patch
@@ -0,0 +1,27 @@
+diff --git /usr/lib/linuxmint/mintLocale/mintLocale.py /usr/lib/linuxmint/mintLocale/mintLocale.py
+--- /usr/lib/linuxmint/mintLocale/mintLocale.py
++++ /usr/lib/linuxmint/mintLocale/mintLocale.py
+This patch removes the options to Add/Remove Languages in Language Settings, as ArchLinux does not use apt (hence no apt_pkg option is available).
+index 990e39b..89267b5 100755
+@@ -14,7 +14,6 @@
+ import ConfigParser
+ import grp
+ import locale
+- import apt
+ import tempfile
+ from subprocess import Popen
+ except Exception, detail:
+@@ -396,7 +395,12 @@
+ self.accountService = AccountsService.UserManager.get_default().get_user(current_user)
+ self.accountService.connect('notify::is-loaded', self.accountservice_ready)
+ self.accountService.connect('changed::', self.accountservice_changed)
+-
++
++ try:
++ import apt_pkg
++ except ImportError:
++ return
++
+ groups = grp.getgrall()
+ for group in groups:
+ (name, pw, gid, mem) = group