summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-08-03 13:24:09 -0400
committerSolomon Choina2018-08-03 13:24:09 -0400
commit6c8df71678ca83e882e88d75d2a273b16c34e3b5 (patch)
treed1db1cf3a429ff34b2982a90c857254da70ade9f
downloadaur-6c8df71678ca83e882e88d75d2a273b16c34e3b5.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--arch-compat.patch26
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a534604cc3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mintmenu
+ pkgdesc = Mint Menu for MATE
+ pkgver = 5.9.0
+ pkgrel = 1
+ url = https://github.com/linuxmint/mintmenu
+ arch = any
+ license = GPL2
+ depends = mate-panel
+ depends = xdg-utils
+ depends = python2
+ optdepends = mint-translations: translations files
+ optdepends = mate-screensaver: lock screen button
+ optdepends = pamac: package manager button
+ source = https://github.com/linuxmint/mintmenu/archive/5.9.0.tar.gz
+ source = arch-compat.patch
+ sha256sums = c2d2a2e7a84a07c0277440b6ee82e96c4575b6e9c5b2bbdc6dcd2779db13a51a
+ sha256sums = 5bc384c52d437cf00b3824e7cf783de080841f1a34c6f85db0328b13e72c983f
+
+pkgname = mintmenu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b645fd289fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Solomon Choina <shlomochoina@gmail.com
+pkgname=mintmenu
+pkgver=5.9.0
+pkgrel=1
+pkgdesc="Mint Menu for MATE"
+arch=('any')
+url="https://github.com/linuxmint/mintmenu"
+license=('GPL2')
+depends=('mate-panel' 'xdg-utils' 'python2')
+optdepends=('mint-translations: translations files'
+ 'mate-screensaver: lock screen button'
+ 'pamac: package manager button'
+)
+source=("${url}/archive/${pkgver}.tar.gz"
+ 'arch-compat.patch')
+sha256sums=('c2d2a2e7a84a07c0277440b6ee82e96c4575b6e9c5b2bbdc6dcd2779db13a51a'
+ '5bc384c52d437cf00b3824e7cf783de080841f1a34c6f85db0328b13e72c983f')
+
+
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch -Np1 -i ../arch-compat.patch
+
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ cp -R usr "$pkgdir/"
+ cd "$pkgdir"/usr/lib/linuxmint/mintMenu
+ ./compile.py
+}
diff --git a/arch-compat.patch b/arch-compat.patch
new file mode 100644
index 000000000000..903384e3c6b3
--- /dev/null
+++ b/arch-compat.patch
@@ -0,0 +1,26 @@
+From 8e093738cae24a30b3e11293e5b0de06a04f94c0 Mon Sep 17 00:00:00 2001
+From: SolarAquarion <shlomochoina@gmail.com>
+Date: Fri, 3 Aug 2018 13:06:58 -0400
+Subject: [PATCH] Update system_management.py
+
+---
+ usr/lib/linuxmint/mintMenu/plugins/system_management.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/usr/lib/linuxmint/mintMenu/plugins/system_management.py b/usr/lib/linuxmint/mintMenu/plugins/system_management.py
+index 2d5e1c1..1126aab 100755
+--- a/usr/lib/linuxmint/mintMenu/plugins/system_management.py
++++ b/usr/lib/linuxmint/mintMenu/plugins/system_management.py
+@@ -161,10 +161,10 @@ def do_standard_items( self ):
+
+ if ( self.showPackageManager == True ):
+ Button2 = easyButton( "applications-system", self.iconsize, [_("Package Manager")], -1, -1 )
+- Button2.connect( "clicked", self.ButtonClicked, "synaptic-pkexec" )
++ Button2.connect( "clicked", self.ButtonClicked, "pamac-manager" )
+ Button2.show()
+ self.systemBtnHolder.pack_start( Button2, False, False, 0 )
+- self.mintMenuWin.setTooltip( Button2, _("Install, remove and upgrade software packages") )
++ self.mintMenuWin.setTooltip( Button2, _("Install, remove, and upgrade software packages") )
+
+ if ( self.showControlCenter == True ):
+ Button3 = easyButton( "gtk-preferences", self.iconsize, [_("Control Center")], -1, -1 )