summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-03-17 10:29:05 -0400
committerSolomon Choina2020-03-17 10:29:05 -0400
commit7545f01154415095ba219e2c2d46740d4cbc3ff7 (patch)
treeeaab89bc395cea95af4dd718a76d1354b8cba70b
parent6c8df71678ca83e882e88d75d2a273b16c34e3b5 (diff)
downloadaur-7545f01154415095ba219e2c2d46740d4cbc3ff7.tar.gz
updpkgver and adding depends
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--arch-compat.patch35
3 files changed, 34 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a534604cc3d..67b0eb4e88f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = mintmenu
pkgdesc = Mint Menu for MATE
- pkgver = 5.9.0
+ pkgver = 6.0.3
pkgrel = 1
url = https://github.com/linuxmint/mintmenu
arch = any
license = GPL2
+ makedepends = git
depends = mate-panel
depends = xdg-utils
depends = python2
+ depends = python2-gobject
+ depends = python2-xlib
+ depends = python2-setproctitle
optdepends = mint-translations: translations files
optdepends = mate-screensaver: lock screen button
optdepends = pamac: package manager button
- source = https://github.com/linuxmint/mintmenu/archive/5.9.0.tar.gz
+ source = mintmenu-6.0.3::git+https://github.com/linuxmint/mintmenu#commit=e603bee1f36827c1f2a0a44b3d7e422d384599a7
source = arch-compat.patch
- sha256sums = c2d2a2e7a84a07c0277440b6ee82e96c4575b6e9c5b2bbdc6dcd2779db13a51a
- sha256sums = 5bc384c52d437cf00b3824e7cf783de080841f1a34c6f85db0328b13e72c983f
+ sha256sums = SKIP
+ sha256sums = ad3b5267206782ea5631d030dc827b7f24c5eb6d5b71964d432e3ccb19266a9f
pkgname = mintmenu
diff --git a/PKGBUILD b/PKGBUILD
index 4b645fd289fc..57e7b4ca4ec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com
pkgname=mintmenu
-pkgver=5.9.0
+pkgver=6.0.3
pkgrel=1
pkgdesc="Mint Menu for MATE"
arch=('any')
url="https://github.com/linuxmint/mintmenu"
license=('GPL2')
-depends=('mate-panel' 'xdg-utils' 'python2')
+depends=('mate-panel' 'xdg-utils' 'python2' 'python2-gobject'
+ 'python2-xlib' 'python2-setproctitle')
+makedepends=('git')
optdepends=('mint-translations: translations files'
'mate-screensaver: lock screen button'
'pamac: package manager button'
)
-source=("${url}/archive/${pkgver}.tar.gz"
+source=("$pkgname-$pkgver::git+$url#commit=e603bee1f36827c1f2a0a44b3d7e422d384599a7"
'arch-compat.patch')
-sha256sums=('c2d2a2e7a84a07c0277440b6ee82e96c4575b6e9c5b2bbdc6dcd2779db13a51a'
- '5bc384c52d437cf00b3824e7cf783de080841f1a34c6f85db0328b13e72c983f')
+sha256sums=('SKIP'
+ 'ad3b5267206782ea5631d030dc827b7f24c5eb6d5b71964d432e3ccb19266a9f')
prepare() {
@@ -27,5 +29,6 @@ package() {
cd "$srcdir/${pkgname}-${pkgver}"
cp -R usr "$pkgdir/"
cd "$pkgdir"/usr/lib/linuxmint/mintMenu
- ./compile.py
+ find . -type f -name '*.py' | xargs -n1 python3 -m compileall .
+
}
diff --git a/arch-compat.patch b/arch-compat.patch
index 903384e3c6b3..402705945e5b 100644
--- a/arch-compat.patch
+++ b/arch-compat.patch
@@ -1,26 +1,25 @@
-From 8e093738cae24a30b3e11293e5b0de06a04f94c0 Mon Sep 17 00:00:00 2001
-From: SolarAquarion <shlomochoina@gmail.com>
-Date: Fri, 3 Aug 2018 13:06:58 -0400
-Subject: [PATCH] Update system_management.py
+From 933c13f72b14214c70f688bcee01ad386dc3ed46 Mon Sep 17 00:00:00 2001
+From: Solomon Choina <shlomochoina@gmail.com>
+Date: Mon, 16 Mar 2020 10:28:10 -0400
+Subject: [PATCH] arch-compat
---
- usr/lib/linuxmint/mintMenu/plugins/system_management.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
+ usr/lib/linuxmint/mintMenu/plugins/system_management.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/usr/lib/linuxmint/mintMenu/plugins/system_management.py b/usr/lib/linuxmint/mintMenu/plugins/system_management.py
-index 2d5e1c1..1126aab 100755
+index 5b5ef8c..c7a3c7e 100755
--- a/usr/lib/linuxmint/mintMenu/plugins/system_management.py
+++ b/usr/lib/linuxmint/mintMenu/plugins/system_management.py
-@@ -161,10 +161,10 @@ def do_standard_items( self ):
+@@ -152,7 +152,7 @@ class pluginclass(object):
- if ( self.showPackageManager == True ):
- Button2 = easyButton( "applications-system", self.iconsize, [_("Package Manager")], -1, -1 )
-- Button2.connect( "clicked", self.ButtonClicked, "synaptic-pkexec" )
-+ Button2.connect( "clicked", self.ButtonClicked, "pamac-manager" )
+ if self.showPackageManager:
+ Button2 = easyButton("applications-system", self.iconsize, [_("Package Manager")], -1, -1)
+- Button2.connect("clicked", self.ButtonClicked, "synaptic-pkexec")
++ Button2.connect("clicked", self.ButtonClicked, "pamac-manager")
Button2.show()
- self.systemBtnHolder.pack_start( Button2, False, False, 0 )
-- self.mintMenuWin.setTooltip( Button2, _("Install, remove and upgrade software packages") )
-+ self.mintMenuWin.setTooltip( Button2, _("Install, remove, and upgrade software packages") )
-
- if ( self.showControlCenter == True ):
- Button3 = easyButton( "gtk-preferences", self.iconsize, [_("Control Center")], -1, -1 )
+ self.systemBtnHolder.pack_start(Button2, False, False, 0)
+ self.mintMenuWin.setTooltip(Button2, _("Install, remove and upgrade software packages"))
+--
+2.25.1
+