summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-12-03 20:56:03 +0100
committerwillemw122023-12-03 20:56:03 +0100
commite221de29470968f6ecb0fbe8e39689c77917e060 (patch)
tree5b8171ba821ccb918f23a698618f989458b57d3d
parent0ac5551fea865859b69efe8d50e7048fff1b1462 (diff)
downloadaur-e221de29470968f6ecb0fbe8e39689c77917e060.tar.gz
Switch to Debian install file
Minor edits.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a11d5311db5..88806a4d2de9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mintstick-git
pkgdesc = Format or write images to USB sticks (Linux Mint tool)
- pkgver = r245.b7f43d2
+ pkgver = r270.1e49c7f
pkgrel = 1
url = https://github.com/linuxmint/mintstick
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 0d6ad1ea36f6..e606a2aae28e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: unclesam <web _AT_ shinobi-mail _DOT_ de>
pkgname=mintstick-git
-pkgver=r245.b7f43d2
+pkgver=r270.1e49c7f
pkgrel=1
-pkgdesc="Format or write images to USB sticks (Linux Mint tool)"
-arch=('any')
-url="https://github.com/linuxmint/mintstick"
-license=('GPL')
-depends=('dosfstools' 'python-dbus' 'python-gobject' 'python-pyparted' 'python-xapp' 'udisks2' 'xapps')
+pkgdesc='Format or write images to USB sticks (Linux Mint tool)'
+arch=(any)
+url=https://github.com/linuxmint/mintstick
+license=(GPL)
+depends=(dosfstools python-dbus python-gobject python-pyparted python-xapp udisks2 xapps)
optdepends=('dosfstools: FAT filesystems' 'e2fsprogs: Ext filesystems' 'ntfs-3g: NTFS filesystems')
-makedepends=('git')
+makedepends=(git)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
@@ -23,19 +23,17 @@ pkgver() {
prepare() {
sed -i -e '/.*kde4.*/d' \
- -e 's/mintstick.glade//g' \
- -e 's/org.linuxmint.im.policy/com.linuxmint.mintstick.policy/g' \
- -e 's| /usr| "'$pkgdir'"/usr|g' \
- $pkgname/install.sh
+ -e 's| /usr| usr|' \
+ -e 's| usr| "'"$pkgdir"'"/usr|' \
+ -e 's|^|cp |' \
+ $pkgname/debian/install
}
package() {
install -dm755 "$pkgdir/usr/bin"
- install -dm755 "$pkgdir/usr/share/"{applications,polkit-1/actions}
-
- cp -a $pkgname/share/nemo "$pkgdir/usr/share"
+ install -dm755 "$pkgdir/usr/lib/mintstick"
+ install -dm755 "$pkgdir/usr/share/"{applications,mintstick,nemo/actions,polkit-1/actions}
cd $pkgname
- ./install.sh
+ sh ./debian/install
}
-