summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqueueRAM2020-12-07 07:50:20 +0000
committerqueueRAM2020-12-07 07:50:20 +0000
commit611858cf89b25f1f33cb9fa97a7924e16328d1e1 (patch)
treea3813f630ca9b351a4d3979a9f3960964d8c076c
downloadaur-611858cf89b25f1f33cb9fa97a7924e16328d1e1.tar.gz
Initial commit of mips-linux-binutils-bin 2.9.5
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c26bf5a22631
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mips-linux-binutils-bin
+ pkgdesc = A set of programs to assemble and manipulate binary and object files (mips-linux)
+ pkgver = 2.9.5
+ pkgrel = 1
+ url = http://www.gnu.org/software/binutils/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ options = !strip
+ source = https://www.linux-mips.org/pub/linux/mips/crossdev/i686-linux/mips-linux/binutils-mips-linux-2.9.5-3.i386.rpm
+ sha256sums = 1da33af71b846f40f28dd8cc07c9742cafb9352a53b81d0bac0d18cf503b98ad
+ depends_i686 = glibc
+ depends_x86_64 = lib32-glibc
+
+pkgname = mips-linux-binutils-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f22c73a2478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: queueRAM <queueRAM+aur AT gmail.com>
+
+pkgname=mips-linux-binutils-bin
+pkgver=2.9.5
+pkgrel=1
+pkgdesc="A set of programs to assemble and manipulate binary and object files (mips-linux)"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.gnu.org/software/binutils/"
+depends_i686=('glibc')
+depends_x86_64=('lib32-glibc')
+options=('!strip')
+source=("https://www.linux-mips.org/pub/linux/mips/crossdev/i686-linux/mips-linux/binutils-mips-linux-${pkgver}-3.i386.rpm")
+sha256sums=('1da33af71b846f40f28dd8cc07c9742cafb9352a53b81d0bac0d18cf503b98ad')
+
+package() {
+ install -dm755 "${pkgdir}/usr/share"
+ cp -a ${srcdir}/usr/bin ${pkgdir}/usr
+ cp -a ${srcdir}/usr/man ${pkgdir}/usr/share
+ cp -a ${srcdir}/usr/mips-linux ${pkgdir}/usr
+}