summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2023-10-03 02:31:19 +0200
committerGaël PORTAY2023-10-03 02:31:19 +0200
commit1c43abcb73d8bd6ae2ca5043f3b527081a305342 (patch)
tree20de1d6f2231dca759f586b4b1c6583e6e95c32f
parentb28e8ff3bfe8d10d1c870ba95d0fe189140e623f (diff)
downloadaur-1c43abcb73d8bd6ae2ca5043f3b527081a305342.tar.gz
v2023.08-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
-rw-r--r--hooks.install-mips32el-glibc-bleeding-edge-toolchain7
-rw-r--r--profile.sh-mips32el-glibc-bleeding-edge-toolchain3
4 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9282a3f22254..76bcd0b43c4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,10 +3,13 @@ pkgbase = mips32el-glibc-bleeding-edge-toolchain
pkgver = 2023.08
pkgrel = 1
url = https://toolchains.bootlin.com/
+ install = hooks.install-mips32el-glibc-bleeding-edge-toolchain
arch = x86_64
license = GPL
source = https://toolchains.bootlin.com/downloads/releases/toolchains/mips32el/tarballs/mips32el--glibc--bleeding-edge-2023.08-1.tar.bz2
+ source = profile.sh-mips32el-glibc-bleeding-edge-toolchain
sha256sums = 190300b5a7056f3b5cc5de1637fe8f52d74aad1b0335b2291c46341c6e4589e4
+ sha256sums = 80373fb6b96f0549b719393c9538dd6549dc0adaeac2c7b7582dcec02c9ffbe4
pkgname = mips32el-glibc-bleeding-edge-toolchain
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 014111e97e8f..824a70e387ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,11 @@ pkgdesc="Ready-to-use cross-compilation toolchain provided by bootlin.com"
arch=("x86_64")
url="https://toolchains.bootlin.com/"
license=("GPL")
-source=("https://toolchains.bootlin.com/downloads/releases/toolchains/mips32el/tarballs/mips32el--glibc--bleeding-edge-2023.08-1.tar.bz2")
-sha256sums=('190300b5a7056f3b5cc5de1637fe8f52d74aad1b0335b2291c46341c6e4589e4')
+source=("https://toolchains.bootlin.com/downloads/releases/toolchains/mips32el/tarballs/mips32el--glibc--bleeding-edge-2023.08-1.tar.bz2"
+ "profile.sh-mips32el-glibc-bleeding-edge-toolchain")
+install="hooks.install-mips32el-glibc-bleeding-edge-toolchain"
+sha256sums=('190300b5a7056f3b5cc5de1637fe8f52d74aad1b0335b2291c46341c6e4589e4'
+ '80373fb6b96f0549b719393c9538dd6549dc0adaeac2c7b7582dcec02c9ffbe4')
build() {
cd "mips32el--glibc--bleeding-edge-2023.08-1"
@@ -24,4 +27,7 @@ package() {
mkdir -p "$pkgdir/opt/mips32el-glibc-bleeding-edge/"
cp -a * "$pkgdir/opt/mips32el-glibc-bleeding-edge/"
rm -f "$pkgdir/opt/mips32el-glibc-bleeding-edge/{buildroot.config,relocate-sdk.sh,summary.csv,share/buildroot/sdk-location}"
+
+ mkdir -p "$pkgdir/etc/profile.d/"
+ install -m0644 "$srcdir/profile.sh-mips32el-glibc-bleeding-edge-toolchain" "$pkgdir/etc/profile.d/mips32el-glibc-bleeding-edge-toolchain.sh"
}
diff --git a/hooks.install-mips32el-glibc-bleeding-edge-toolchain b/hooks.install-mips32el-glibc-bleeding-edge-toolchain
new file mode 100644
index 000000000000..bc34701c714e
--- /dev/null
+++ b/hooks.install-mips32el-glibc-bleeding-edge-toolchain
@@ -0,0 +1,7 @@
+post_install() {
+ echo "bootlin toolchain installed to /opt/mips32el-glibc-bleeding-edge"
+ echo "The PATH variable will be updated on re-login. To immediately load it:"
+ echo ""
+ echo " source /etc/profile.d/mips32el-glibc-bleeding-edge.sh"
+ echo ""
+}
diff --git a/profile.sh-mips32el-glibc-bleeding-edge-toolchain b/profile.sh-mips32el-glibc-bleeding-edge-toolchain
new file mode 100644
index 000000000000..dc534e1a0fd8
--- /dev/null
+++ b/profile.sh-mips32el-glibc-bleeding-edge-toolchain
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+export PATH="$PATH:/opt/mips32el-glibc-bleeding-edge/bin"