summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValentin2017-08-10 15:53:11 +0200
committerValentin2017-08-10 15:53:11 +0200
commite55eaade5befc2caaa321545d343079eda14df8d (patch)
tree79df511e6ba9d4167cf035dda609eba47756393a
downloadaur-e55eaade5befc2caaa321545d343079eda14df8d.tar.gz
Update procedure and name using PKGBUILD from aarch64-linux-gnu-binutils
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD67
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c26e33951fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mips64-linux-gnu-binutils
+ pkgdesc = A set of programs to assemble and manipulate binary and object files for the MIPS64 target (Big Endian)
+ pkgver = 2.29
+ pkgrel = 1
+ url = http://www.gnu.org/software/binutils/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib
+ source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.29.tar.bz2
+ source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.29.tar.bz2.sig
+ validpgpkeys = EAF1C276A747E9ED86210CBAC3126D3B4AE55E93
+ sha1sums = 4376bce1e58d591c6a5dd44fc8713f154208d735
+ sha1sums = SKIP
+
+pkgname = mips64-linux-gnu-binutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43929f61fd85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# $Id$
+# Creator Anatol Pomozov <anatol.pomozov@gmail.com>
+# Adapt for MIPS64: Valentín Kivachuk <vk18496@gmail.com>
+
+_target=mips64-linux-gnu
+pkgname=$_target-binutils
+pkgver=2.29
+pkgrel=1
+#_commit=2bd25930
+pkgdesc='A set of programs to assemble and manipulate binary and object files for the MIPS64 target (Big Endian)'
+arch=(i686 x86_64)
+url='http://www.gnu.org/software/binutils/'
+license=(GPL)
+depends=(zlib)
+source=(ftp://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
+sha1sums=('4376bce1e58d591c6a5dd44fc8713f154208d735'
+ 'SKIP')
+validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93') # Tristan Gingold <gingold@adacore.com>
+
+prepare() {
+ cd binutils-$pkgver
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+}
+
+build() {
+ cd binutils-$pkgver
+
+ if [ "${CARCH}" != "i686" ];
+ then
+ # enabling gold linker at i686 makes the install fail
+ enable_gold='--enable-gold'
+ fi
+
+ ./configure --target=$_target \
+ --with-sysroot=/usr/$_target \
+ --prefix=/usr \
+ --disable-multilib \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --disable-nls \
+ --enable-ld=default \
+ $enable_gold \
+ --enable-plugins \
+ --enable-deterministic-archives
+
+ make
+}
+
+check() {
+ cd binutils-$pkgver
+
+ # unset LDFLAGS as testsuite makes assumptions about which ones are active
+ # do not abort on errors - manually check log files
+ make -k LDFLAGS="" check || true
+}
+
+package() {
+ cd binutils-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ # Remove file conflicting with host binutils and manpages for MS Windows tools
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
+
+ # Remove info documents that conflict with host version
+ rm -r "$pkgdir"/usr/share/info
+}