summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-03-13 00:03:57 -0300
committerDaniel Bermond2022-03-13 00:03:57 -0300
commit5fe1d6cd56cf8de09d525d45fe139c0b1313c2c4 (patch)
treeaa7f6aab6a8bf5cd87308f1903b59466872e441c
parentf457d2a7b1a198e3e8c59f92b21186bd7074122e (diff)
downloadaur-5fe1d6cd56cf8de09d525d45fe139c0b1313c2c4.tar.gz
Disable lto and remove an unneeded patch
-rw-r--r--.SRCINFO11
-rw-r--r--010-gcc-fix-build.patch383
-rw-r--r--010-gcc11-Wno-format-security.patch (renamed from 020-gcc11-Wno-format-security.patch)0
-rw-r--r--020-gcc-config-mips-multilib.patch (renamed from 030-gcc-config-mips-multilib.patch)0
-rw-r--r--030-gcc-gdc-phobos-path.patch (renamed from 040-gcc-gdc-phobos-path.patch)0
-rw-r--r--PKGBUILD19
6 files changed, 13 insertions, 400 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c78e31a80026..7ad34b520446 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mips64-linux-gnu-gcc
pkgdesc = The GNU Compiler Collection - cross compiler for the MIPS64 target (for the toolchain with GNU C library and with multilib ABI)
pkgver = 11.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://gcc.gnu.org/
arch = x86_64
license = GPL
@@ -28,19 +28,18 @@ pkgbase = mips64-linux-gnu-gcc
options = !emptydirs
options = !strip
options = staticlibs
+ options = !lto
source = https://sourceware.org/pub/gcc/releases/gcc-11.2.0/gcc-11.2.0.tar.xz
source = https://sourceware.org/pub/gcc/releases/gcc-11.2.0/gcc-11.2.0.tar.xz.sig
source = https://sourceforge.net/projects/libisl/files/isl-0.24.tar.xz
- source = 010-gcc-fix-build.patch
- source = 020-gcc11-Wno-format-security.patch
- source = 030-gcc-config-mips-multilib.patch
- source = 040-gcc-gdc-phobos-path.patch
+ source = 010-gcc11-Wno-format-security.patch
+ source = 020-gcc-config-mips-multilib.patch
+ source = 030-gcc-gdc-phobos-path.patch
validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
validpgpkeys = 33C235A34C46AA3FFB293709A328C3A2C3C45C06
sha256sums = d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b
sha256sums = SKIP
sha256sums = 043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad
- sha256sums = 6b3a5608bcb7bba042b25aab518c7f8dc50180174d53d5f4bbe381c9b0132e27
sha256sums = 504e4b5a08eb25b6c35f19fdbe0c743ae4e9015d0af4759e74150006c283585e
sha256sums = 1e3184b9ddacf7ba6a1621f7e1f0aace76d76f791fca8fd3bdd855dc7a43356e
sha256sums = aaee7a90b07184740198a9a6fe16115743c3836a7f54ce7e09fd48ae8e0222ba
diff --git a/010-gcc-fix-build.patch b/010-gcc-fix-build.patch
deleted file mode 100644
index a2a07179df85..000000000000
--- a/010-gcc-fix-build.patch
+++ /dev/null
@@ -1,383 +0,0 @@
---- a/gcc/configure
-+++ b/gcc/configure
-@@ -3318,7 +3318,7 @@ fi
- ## -------------------- ##
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -3949,7 +3949,7 @@ rm -f a.out a.exe b.out
-
- # Find the native compiler
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -4732,13 +4732,13 @@ if test "x$ac_cv_prog_cc_c89" != xno; th
- fi
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -4989,7 +4989,7 @@ else
- fi
- fi
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -5216,7 +5216,7 @@ fi
-
- # Do configure tests with the C++ compiler, since that's what we build with.
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -5322,7 +5322,7 @@ esac
-
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -5449,7 +5449,7 @@ See \`config.log' for more details" "$LI
- fi
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -5777,7 +5777,7 @@ $as_echo "$ac_cv_safe_to_define___extens
-
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -5908,7 +5908,7 @@ See \`config.log' for more details" "$LI
- fi
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -6838,7 +6838,7 @@ else
- wf_opt=
- fi
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -6888,7 +6888,7 @@ fi
- done
- CXXFLAGS="$save_CXXFLAGS"
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -6896,7 +6896,7 @@ ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -6946,14 +6946,14 @@ fi
- done
- CFLAGS="$save_CFLAGS"
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -7003,14 +7003,14 @@ fi
- done
- CXXFLAGS="$save_CXXFLAGS"
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -7060,14 +7060,14 @@ fi
- done
- CFLAGS="$save_CFLAGS"
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -7109,14 +7109,14 @@ fi
-
- fi
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -7133,7 +7133,7 @@ if test $enable_werror_always = yes; the
- fi
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -7154,7 +7154,7 @@ fi
-
- # Disable exceptions and RTTI if building with g++
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -7204,7 +7204,7 @@ fi
- done
- CFLAGS="$save_CFLAGS"
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -9400,7 +9400,7 @@ $as_echo "#define AC_APPLE_UNIVERSAL_BUI
- # ----------------------
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -9529,7 +9529,7 @@ See \`config.log' for more details" >&2;
- fi
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -15226,7 +15226,7 @@ if ${lt_cv_cc_needs_belf+:} false; then
- $as_echo_n "(cached) " >&6
- else
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -15250,7 +15250,7 @@ fi
- rm -f core conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -16313,7 +16313,7 @@ esac
-
- lt_save_CC="$CC"
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -19708,7 +19708,7 @@ $as_echo "$enable_static" >&6; }
-
- fi
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -19719,7 +19719,7 @@ CC="$lt_save_CC"
- ( (test "X$CXX" = "Xg++" && `g++ -v >/dev/null 2>&1` ) ||
- (test "X$CXX" != "Xg++"))) ; then
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -19846,7 +19846,7 @@ See \`config.log' for more details" "$LI
- fi
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -19856,7 +19856,7 @@ else
- fi
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-@@ -22721,7 +22721,7 @@ fi
- fi # test "$_lt_caught_CXX_error" != yes
-
- ac_ext=cpp
--ac_cpp='$CXXCPP $CPPFLAGS'
-+ac_cpp='$CXXCPP $CPPFLAGS -O2'
- ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
---- a/libiberty/configure
-+++ b/libiberty/configure
-@@ -2450,7 +2450,7 @@ fi
- ## -------------------- ##
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -2981,7 +2981,7 @@ $as_echo "$as_me: target_header_dir = $t
-
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -3793,14 +3793,14 @@ if test "x$ac_cv_prog_cc_c89" != xno; th
- fi
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -3931,7 +3931,7 @@ See \`config.log' for more details" "$LI
- fi
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -4462,7 +4462,7 @@ fi
- ac_c_preproc_warn_flag=yes
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -4514,14 +4514,14 @@ fi
- done
- CFLAGS="$save_CFLAGS"
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-
-
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
-@@ -4563,7 +4563,7 @@ fi
-
- fi
- ac_ext=c
--ac_cpp='$CPP $CPPFLAGS'
-+ac_cpp='$CPP $CPPFLAGS -O2'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
- ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_c_compiler_gnu
diff --git a/020-gcc11-Wno-format-security.patch b/010-gcc11-Wno-format-security.patch
index 974ea44d0f85..974ea44d0f85 100644
--- a/020-gcc11-Wno-format-security.patch
+++ b/010-gcc11-Wno-format-security.patch
diff --git a/030-gcc-config-mips-multilib.patch b/020-gcc-config-mips-multilib.patch
index 22c727deadf7..22c727deadf7 100644
--- a/030-gcc-config-mips-multilib.patch
+++ b/020-gcc-config-mips-multilib.patch
diff --git a/040-gcc-gdc-phobos-path.patch b/030-gcc-gdc-phobos-path.patch
index e87bd281b29b..e87bd281b29b 100644
--- a/040-gcc-gdc-phobos-path.patch
+++ b/030-gcc-gdc-phobos-path.patch
diff --git a/PKGBUILD b/PKGBUILD
index 61af3f98d86c..02faedda605c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname="${_target}-gcc"
pkgver=11.2.0
_islver=0.24
_majorver="${pkgver%%.*}"
-pkgrel=2
+pkgrel=3
pkgdesc='The GNU Compiler Collection - cross compiler for the MIPS64 target (for the toolchain with GNU C library and with multilib ABI)'
arch=('x86_64')
url='https://gcc.gnu.org/'
@@ -17,18 +17,16 @@ provides=('mips64-linux-gnuabi64-gcc' 'mips64-linux-gnuabi32-gcc'
'mips64-linux-gnuabin32-gcc' "${pkgname}-bootstrap")
conflicts=('mips64-linux-gnuabi64-gcc' 'mips64-linux-gnuabi32-gcc'
'mips64-linux-gnuabin32-gcc' "${pkgname}-bootstrap")
-options=('!emptydirs' '!strip' 'staticlibs')
+options=('!emptydirs' '!strip' 'staticlibs' '!lto')
source=("https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz"{,.sig}
#"http://isl.gforge.inria.fr/isl-${_islver}.tar.xz"
"https://sourceforge.net/projects/libisl/files/isl-${_islver}.tar.xz"
- '010-gcc-fix-build.patch'
- '020-gcc11-Wno-format-security.patch'
- '030-gcc-config-mips-multilib.patch'
- '040-gcc-gdc-phobos-path.patch')
+ '010-gcc11-Wno-format-security.patch'
+ '020-gcc-config-mips-multilib.patch'
+ '030-gcc-gdc-phobos-path.patch')
sha256sums=('d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b'
'SKIP'
'043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad'
- '6b3a5608bcb7bba042b25aab518c7f8dc50180174d53d5f4bbe381c9b0132e27'
'504e4b5a08eb25b6c35f19fdbe0c743ae4e9015d0af4759e74150006c283585e'
'1e3184b9ddacf7ba6a1621f7e1f0aace76d76f791fca8fd3bdd855dc7a43356e'
'aaee7a90b07184740198a9a6fe16115743c3836a7f54ce7e09fd48ae8e0222ba')
@@ -44,10 +42,9 @@ prepare() {
# link isl for in-tree build
ln -s "../isl-${_islver}" "gcc-${pkgver}/isl"
- patch -d "gcc-${pkgver}" -Np1 -i "${srcdir}/010-gcc-fix-build.patch"
- patch -d "gcc-${pkgver}" -Np0 -i "${srcdir}/020-gcc11-Wno-format-security.patch"
- patch -d "gcc-${pkgver}" -Np1 -i "${srcdir}/030-gcc-config-mips-multilib.patch"
- patch -d "gcc-${pkgver}" -Np1 -i "${srcdir}/040-gcc-gdc-phobos-path.patch"
+ patch -d "gcc-${pkgver}" -Np0 -i "${srcdir}/010-gcc11-Wno-format-security.patch"
+ patch -d "gcc-${pkgver}" -Np1 -i "${srcdir}/020-gcc-config-mips-multilib.patch"
+ patch -d "gcc-${pkgver}" -Np1 -i "${srcdir}/030-gcc-gdc-phobos-path.patch"
}
build() {