summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-12-24 17:03:29 -0300
committerDaniel Bermond2021-12-24 17:03:29 -0300
commitf457d2a7b1a198e3e8c59f92b21186bd7074122e (patch)
tree1a9b1715ff6f4d52377b26d8eadeb90a633ec780
parente16b235a42788a53dd6e77cce02fd4784ae8db98 (diff)
downloadaur-f457d2a7b1a198e3e8c59f92b21186bd7074122e.tar.gz
Fix build with new flags
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c28de4a62a5..c78e31a80026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mips64-linux-gnu-gcc
pkgdesc = The GNU Compiler Collection - cross compiler for the MIPS64 target (for the toolchain with GNU C library and with multilib ABI)
pkgver = 11.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://gcc.gnu.org/
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 87a3ed10bf5d..61af3f98d86c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname="${_target}-gcc"
pkgver=11.2.0
_islver=0.24
_majorver="${pkgver%%.*}"
-pkgrel=1
+pkgrel=2
pkgdesc='The GNU Compiler Collection - cross compiler for the MIPS64 target (for the toolchain with GNU C library and with multilib ABI)'
arch=('x86_64')
url='https://gcc.gnu.org/'
@@ -55,8 +55,13 @@ build() {
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- export CFLAGS="${CFLAGS/-pipe/}"
- export CXXFLAGS="${CXXFLAGS/-pipe/}"
+
+ local _opt
+ for _opt in '-pipe' '-Werror=format-security' '-fstack-clash-protection' '-fcf-protection'
+ do
+ export CFLAGS="${CFLAGS/"$_opt"/}"
+ export CXXFLAGS="${CXXFLAGS/"$_opt"/}"
+ done
# position independent code (PIE) is troublesome in MIPS, as
# it can cause this error when building software with gcc: