summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-10-31 15:23:26 -0300
committerDaniel Bermond2021-10-31 15:23:26 -0300
commitf6ddee01903a67ab8f0808a2454705cd806cd164 (patch)
treef4faa2847eb303c0a04816ba2fa34f6e4257c45e
parent886ae5543ff133332dc49608279585b01899f4e6 (diff)
downloadaur-f6ddee01903a67ab8f0808a2454705cd806cd164.tar.gz
Update to version 5.14.15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6605fca57d03..2e15cad3b570 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = mips64-linux-gnu-linux-api-headers
- pkgdesc = Kernel headers sanitized for use in userspace (mips64-linux-gnu)
- pkgver = 4.11
+ pkgdesc = Kernel headers sanitized for use in userspace (MIPS64 target, for the toolchain with GNU C library and multilib ABI)
+ pkgver = 5.14.15
pkgrel = 1
- url = http://www.kernel.org
+ url = https://www.kernel.org
arch = any
license = GPL2
- source = http://www.kernel.org/pub/linux/kernel/v4.x/linux-4.11.tar.xz
- sha1sums = 0d2594b7aa3e79521f229569f9e14dc56bdcbd78
+ makedepends = rsync
+ source = http://www.kernel.org/pub/linux/kernel/v5.x/linux-5.14.15.tar.xz
+ source = http://www.kernel.org/pub/linux/kernel/v5.x/linux-5.14.15.tar.sign
+ validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
+ validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
+ sha256sums = 74f39a0c69e9d7c94d290515645396725e3ce3667b85baf4b3c3f6f303c7a406
+ sha256sums = SKIP
pkgname = mips64-linux-gnu-linux-api-headers
-
diff --git a/PKGBUILD b/PKGBUILD
index 3d2834e5aae9..58ec2c4fa417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
-# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
-# Updated for MIPS64: Valentín Kivachuk <vk18496@gmail.com>
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
+# Contributor: Valentín Kivachuk <vk18496@gmail.com>
_target_arch=mips
_target=mips64-linux-gnu
-pkgname=$_target-linux-api-headers
-pkgver=4.11
+pkgname="${_target}-linux-api-headers"
+pkgver=5.14.15
pkgrel=1
-pkgdesc="Kernel headers sanitized for use in userspace ($_target)"
-arch=(any)
-url='http://www.kernel.org'
-license=(GPL2)
-source=(http://www.kernel.org/pub/linux/kernel/v4.x/linux-$pkgver.tar.xz)
-sha1sums=('0d2594b7aa3e79521f229569f9e14dc56bdcbd78')
+pkgdesc='Kernel headers sanitized for use in userspace (MIPS64 target, for the toolchain with GNU C library and multilib ABI)'
+arch=('any')
+url='https://www.kernel.org'
+license=('GPL2')
+makedepends=('rsync')
+source=("http://www.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/linux-${pkgver}.tar".{xz,sign})
+sha256sums=('74f39a0c69e9d7c94d290515645396725e3ce3667b85baf4b3c3f6f303c7a406'
+ 'SKIP')
+validpgpkeys=('ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E') # Greg Kroah-Hartman
build() {
- cd linux-$pkgver
-
- make ARCH=$_target_arch mrproper
- make ARCH=$_target_arch headers_check
+ make -C "linux-${pkgver}" ARCH="$_target_arch" mrproper headers_check
}
package() {
- cd linux-$pkgver
-
- make INSTALL_HDR_PATH="$pkgdir/usr/$_target/" ARCH=$_target_arch V=0 headers_install
-
- # clean-up unnecessary files generated during install
- find "$pkgdir" \( -name .install -or -name ..install.cmd \) -delete
+ make -C "linux-${pkgver}" INSTALL_HDR_PATH="${pkgdir}/usr/${_target}/" ARCH="${_target_arch}" headers_install
}