summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2020-08-26 07:57:20 -0400
committerJoey Dumont2020-08-26 07:57:20 -0400
commit2176e964a4d987e7ec3a959c629811d16908f60b (patch)
tree5e39cdc092d71cff23ee5790a1a70a381c5c8d5d
parentd35c7ed98cf8741f02d9c3a1947d8b1ec88472e4 (diff)
downloadaur-2176e964a4d987e7ec3a959c629811d16908f60b.tar.gz
Updated to binutils-2.35, and included sysroot in this package, as it is the first one in the toolchain.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8469805bbfc..20ac3cb7bf88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = mips64-ultra-elf-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for mips64-ultra-elf
- pkgver = 2.34_r128.79c3ef4
+ pkgver = 2.35_r134.54b8f95
pkgrel = 1
url = http://www.gnu.org/software/binutils/
arch = x86_64
license = GPL
makedepends = git
depends = libelf
- source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.34.tar.xz
+ source = ftp://ftp.gnu.org/gnu/binutils/binutils-2.35.tar.xz
source = git+https://github.com/glankk/n64.git#branch=n64-ultra
- sha256sums = f00b0e8803dc9bab1e2165bd568528135be734df3fabf8d0161828cd56028952
+ sha256sums = 1b11659fb49e20e18db460d44485f09442c8c56d5df165de9461eb09c8302f85
sha256sums = SKIP
pkgname = mips64-ultra-elf-binutils
diff --git a/PKGBUILD b/PKGBUILD
index 4fe0b61f7566..4cbd02b3c8db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Joey Dumont <joey.dumont@gmail.com>
-
_target=mips64-ultra-elf
pkgname=${_target}-binutils
-_binutilsver=2.34
-pkgver=2.34_r128.79c3ef4
+_binutilsver=2.35
+pkgver=2.35_r134.54b8f95
pkgrel=1
pkgdesc="A set of programs to assemble and manipulate binary and object files for ${_target}"
url="http://www.gnu.org/software/binutils/"
@@ -13,7 +12,7 @@ makedepends=('git')
depends=('libelf')
source=("ftp://ftp.gnu.org/gnu/binutils/binutils-${_binutilsver}.tar.xz"
"git+https://github.com/glankk/n64.git#branch=n64-ultra")
-sha256sums=('f00b0e8803dc9bab1e2165bd568528135be734df3fabf8d0161828cd56028952'
+sha256sums=('1b11659fb49e20e18db460d44485f09442c8c56d5df165de9461eb09c8302f85'
'SKIP')
pkgver() {
@@ -38,6 +37,11 @@ prepare() {
cat "config/ld/configure.tgt.ultra" >> ${CP_DIR}/ld/configure.tgt
cd ${CP_DIR}
+ # -- Configure n64. Note that the sysroot dir is set to $(prefix)$/(target)
+ # -- in the package itself.
+ cd $srcdir/n64
+ ./configure --prefix=/usr/
+
}
build() {
@@ -50,7 +54,7 @@ build() {
./configure \
--target=${_target} \
--prefix=/usr \
- --with-sysroot=/usr/${_target} \
+ --with-sysroot=/usr/${_target}/n64-sysroot/ \
--with-gnu-as \
--with-gnu-ld \
--enable-64-bit-bfd \
@@ -82,4 +86,8 @@ package() {
# Remove info documents that conflict with host version
rm -rf "$pkgdir"/usr/share/info
+
+ # Install the library files in the sysroot.
+ cd $srcdir/n64
+ make DESTDIR="${pkgdir}" install-sys
}