summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2025-02-05 21:28:30 -0500
committerJoey Dumont2025-02-05 21:28:30 -0500
commitb86757bfa5e7da5feaaba979fc64e370da62b851 (patch)
tree5af93eaa373d55d07aba012049e7b2be879ab8a3
parent52c6bdf99f1a6c17d045d5b377121531f9456829 (diff)
downloadaur-b86757bfa5e7da5feaaba979fc64e370da62b851.tar.gz
upgpkg: mips64-ultra-elf-binutils 2.44_r183.813f1ae-1
upgpkg: mips64-ultra-elf-gcc-stage1 14.2.0_r183.813f1ae-1 upgpkg: mips64-ultra-elf-gcc 14.2.0_r183.813f1ae-1 upgpkg: mips64-ultra-elf-gdb 16.2_r183.813f1ae-1 upgpkg: mips64-ultra-elf-newlib 4.5.0.20241231_r183.813f1ae-1 Release new mips64-ultra-elf toolchain.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 372727fae0c8..fd027a020080 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mips64-ultra-elf-newlib
pkgdesc = A C library intended for use on embedded systems (mips64-ultra-elf)
- pkgver = 4.3.0.20230120_r172.97ae725
+ pkgver = 4.5.0.20241231_r183.813f1ae
pkgrel = 1
url = http://sourceware.org/newlib/
arch = x86_64
@@ -9,9 +9,9 @@ pkgbase = mips64-ultra-elf-newlib
makedepends = git
options = !strip
options = !emptydirs
- source = ftp://sourceware.org/pub/newlib/newlib-4.3.0.20230120.tar.gz
+ source = ftp://sourceware.org/pub/newlib/newlib-4.5.0.20241231.tar.gz
source = git+https://github.com/glankk/n64.git#branch=n64-ultra
- sha256sums = 83a62a99af59e38eb9b0c58ed092ee24d700fff43a22c03e433955113ef35150
+ sha256sums = 33f12605e0054965996c25c1382b3e463b0af91799001f5bb8c0630f2ec8c852
sha256sums = SKIP
pkgname = mips64-ultra-elf-newlib
diff --git a/PKGBUILD b/PKGBUILD
index 2ce9fb4d0bc5..3161d394ed5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Joey Dumont <joey.dumont@gmail.com>
_target=mips64-ultra-elf
pkgname=${_target}-newlib
-_newlibver=4.3.0.20230120
-pkgver=4.3.0.20230120_r172.97ae725
+_newlibver=4.5.0.20241231
+pkgver=4.5.0.20241231_r183.813f1ae
pkgrel=1
pkgdesc="A C library intended for use on embedded systems (${_target})"
arch=('x86_64')
@@ -11,8 +11,9 @@ license=('BSD')
makedepends=("${_target}-gcc-stage1" "git")
options=('!strip' '!emptydirs')
source=("ftp://sourceware.org/pub/newlib/newlib-${_newlibver}.tar.gz"
- "git+https://github.com/glankk/n64.git#branch=n64-ultra")
-sha256sums=('83a62a99af59e38eb9b0c58ed092ee24d700fff43a22c03e433955113ef35150'
+ "git+https://github.com/glankk/n64.git#branch=n64-ultra"
+)
+sha256sums=('33f12605e0054965996c25c1382b3e463b0af91799001f5bb8c0630f2ec8c852'
'SKIP')
pkgver() {
@@ -26,11 +27,11 @@ pkgver() {
#}
build() {
+
rm -rf build
mkdir build && cd build
- export CFLAGS_FOR_TARGET="-Os -g -ffunction-sections -fdata-sections"
- export CXXFLAGS_FOR_TARGET="-Os -g -ffunction-sections -fdata-sections"
+ export CFLAGS_FOR_TARGET="-Os -g -fpermissive -ffunction-sections -fdata-sections"
../newlib-${_newlibver}/configure \
--prefix=/usr \